What's new

Type Cover and Windows Button not working

BBilley91

New Member
Hey guys, really like the site so far, I've gotten lots of great tips and advice thus far! I've run into an issue with my SP lately though, and it's really starting to irk me. About 3 or 4 days ago while I was just regularly using my Type Cover, it stopped working entirely (Touchpad and Keyboard). In addition, my Windows Button has stopped working completely (capacitive one), but it will still vibrate when pressed. I've tried uninstalling the drivers for HID compliant Keyboard, restarted and nothing. I've tried the whole restart with cover on, before login, after login, kickstand down and up, but no progress. Last night I refreshed my SP, and it didn't work before and after updating, so it's starting to seem like a hardware fault. What puzzles me is that the computer still recognizes it being there (won't spring up the keyboard when I press a text field when attached). I love my Surface, and don't have Complete (didn't buy online, at FS), and wonder if anyone could help me out? Thanks in advance! :)

Update: Got off the phone with MS, after a good hour and a half, he determined it was an internal issue. My Surface botched an update apparently, and even in the UEFI, it's still not recognizing the Cover. Apparently it just will not recognize it. I'm getting a new SP sent to me this week.
 
Last edited:

Lolvo

New Member
There have been one or two other threads here about this specific problem, and from what I read, it seems to pertain to the Surface Pro. On my RT, I sometimes experience the same issue with the Windows Button; haptic feedback is there, but the button does nothing on the device. This problem is on and off and usually resolves itself after a few minutes. As for the keyboard, there isn't much I can advise on other than making sure the leads of both the keyboard and the surface are clean and receptive - clear of any dirt or dust that could be interfering with a connection. Be sure to search and check out the other threads containing this issue.

There have been instances of simply a defective keyboard, let's hope yours is not.
 
Search tags for this page

surface pro 3 keyboard not working

surface pro 3 not recognizing keyboard
surface pro 3 type cover not working
surface pro windows button not working
surface type cover keyboard not working

surface type cover keys not working

surface type cover not working

surface type keyboard not working
surface volume button not working
windows button not working on microsoft surface

Members online

Top