What's new

Why is my internal mic "unplugged" and how to I re-enable it?


New Member
I have a 32GB Surface RT. I noticed that people on Skype can't hear me, so I looked at the app's settings and found that Mic is set to "Use Default Device," but there are no individual devices listed (the speakers and webcam are also set to "Use Default Device," but they list the integrated speakers and webcam as options). So I dropped into the Desktop, right clicked the sound icon on the taskbar, and clicked Recording Devices.

It shows a single device - Microphone > NVIDIA Tegra Wave Device. The device looks disabled (the icon is semi-transparent), there's a little red down arrow next to it, and the status reads "not plugged in." Not disabled, but not plugged in. The Configure button is also disabled. If I click Properties, I can see the controller information and that the device appears to be enabled. Looking at the controller properties, all the driver details seem to be in order.

FWIW, I tried disabling the controller and rebooting, which also took out the sound. So I tried re-enabling the device, and the sound came back just fine, but the mic still says it's "not plugged in." Any ideas?
Welcome to the forum Greg. That is the way it should be. The "Microphone" is apparently for the headphone jack. You should have a second device (check again now that you rebooted) called "Microphone Array - NVIDIA Tegra Wave Device". This is the built in mic.
You should see two input devices-

When i plug my Altec MZX406 that has a built-in mic that I use for Skype, the second device will activate and the Microphone Array (built-in mic) will deactivate.
Last edited:
Good advice, folks. I didn't see it, because the list had been set to hide disabled devices. Now that I know what I'm looking for, it was much easier to enable it. Thanks!