Activating the Type Clicking Noise?

Discussion in 'Microsoft Surface Pro 2' started by clemgrad85, Feb 27, 2014.

  1. clemgrad85

    clemgrad85 Member

    Joined:
    Jan 26, 2014
    Messages:
    49
    Likes Received:
    1
    Trophy Points:
    8
    Well....so this morning I start to type on my Type Cover and it is making a "clicking" sound each time I type a key. At first this annoyed me, but then I realized I was actually typing better for some reason and started to like hearing the sound. Well, I must have hit a button again because now the clicking sound is gone. Does anyone know how to toggle that on and off? Thanks.....
     
  2. jefhart

    jefhart Member

    Joined:
    Jan 2, 2014
    Messages:
    181
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Cincinnati
    My Device:
    SPro2
    Settings > change pc settings>pc and devices>typing>sound is towards the bottom
     
  3. jrapdx

    jrapdx Member

    Joined:
    Jan 14, 2014
    Messages:
    259
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Oregon
    There might be more than one way to do this, but from the touch/tiles screen swipe from right, hit Settings, then Change PC Settings, then PC & Devices, then Typing. Under Touch Keyboard, first "switch" is Keyboard Noise.

    On this SP2 it's off. To me it's an annoyance, and completely unnecessary with the Covers, especially the Type Cover. But hey, each to their own.

    I do strongly suggest turning the sound off if you are using the SP2 in a public setting, for example, at a conference where people are all around. The sounds can be distracting to others. While I'm on the subject, in such situations it's also a good and kind idea to turn the screen brightness down--a brilliantly luminous object could be a distraction to people around or behind your location.
     
  4. clemgrad85

    clemgrad85 Member

    Joined:
    Jan 26, 2014
    Messages:
    49
    Likes Received:
    1
    Trophy Points:
    8
    Thanks for the info. What is odd is I never went to these locations to change the typing sound and yet it wasn't originally on, and then it was on, and then it was off again. When I went to the locations you both mentioned, it said the sound was on....but....as I type now the only sound is the sound of my fingers typing, not the clicking sound. There must be a shortcut on the keyboard that I accidently triggered and that turned the sound on and then back off again....or....this is just one of those nutty little issues. The only thing I did was connect the keyboard to the SP2 (I use the Bluetooth adapter most of the time as I have the SP2 in a docking station) and once I did that, no more clicking sounds. Not a big deal, but now just curious as to what triggered it on and off.
     
  5. jrapdx

    jrapdx Member

    Joined:
    Jan 14, 2014
    Messages:
    259
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Oregon
    Have no idea if it has anything to do with what you've described, but quite a number of times the system sound settings change without my deliberate action to change it.

    Normally sound is muted on my SP2. My personal weirdness: I dislike machines talking, beeping or clattering at me. Please, I say, there's already enough noise in the world, I don't need more. Besides, there's seldom any additional information in it. Yes I can see that huge banner warning me the battery is getting low, adding noise is redundant.

    But for reasons unknown, all of sudden the sound blares or bellows, sure enough the "mute" setting has been cancelled. Of course, I reset mute to "on", and peace and quiet is restored, but sure enough within a day or two it happens again.

    The upshot of my rant is that you should check sound settings: apparently they can change through some spooky, self-willed and unpredictable mechanism afflicting the SP2.

    As an aside, the sound drivers were found to be somehow affecting cold boot and CPU misbehavior. I'm beginning to wonder if the sound drivers are implicated in widespread, if unintended, effects on other SP2 subsystems in non-obvious ways. I'm very glad I'm not responsible for debugging such problems. They are the stuff of nightmares.
     
  6. Sir Face

    Sir Face New Member

    Joined:
    Jan 31, 2014
    Messages:
    96
    Likes Received:
    5
    Trophy Points:
    0
    This process only works for the on-screen keyboard. I need it to work for the type cover keys... is that possible?
     
    Last edited: Feb 28, 2014
  7. Dayton

    Dayton Member

    Joined:
    Dec 19, 2013
    Messages:
    75
    Likes Received:
    2
    Trophy Points:
    8
    Make sure you aren't "muted", I notice my Touch Cover likes to put the SP2 in "mute".
     
  8. Sir Face

    Sir Face New Member

    Joined:
    Jan 31, 2014
    Messages:
    96
    Likes Received:
    5
    Trophy Points:
    0
    'Still don't work for me with the type cover keyboard no matter how high the volume.
     
  9. jimkraz

    jimkraz Member

    Joined:
    Jun 21, 2013
    Messages:
    63
    Likes Received:
    5
    Trophy Points:
    8
    Turning on the sound in settings/PCs and Devices should turn on your sound for keyboard, I had the same problem with my touch keyboard, it was turned off, I turned it on, then a restart was required to bring sound on.
     
  10. jrapdx

    jrapdx Member

    Joined:
    Jan 14, 2014
    Messages:
    259
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Oregon
    Strangely, my SP2 sporadically and for no clear reason turns muting off, that is, "unmutes" the sound on its own accord. Very annoying when the SP2 acts against our wishes in ways we don't want and didn't expect.
     
  11. clemgrad85

    clemgrad85 Member

    Joined:
    Jan 26, 2014
    Messages:
    49
    Likes Received:
    1
    Trophy Points:
    8
    Quite odd.....no matter what I do, mute on, mute off....still can't get the clicking noise. Jrap, I agree, I normally don't like such sounds either, but as I stated in my original post, for some reason hearing the clicking sounds had me typing better....weird. I didn't even know there could be clicking noises until they suddenly showed up yesterday. That's why I think there is something on the keyboard....a shortcut....that I accidently hit. I did not make any adjustments to the sounds on the SP2 to either turn it on, or then turn it off. Grrrrrrr. I will add....this is a very minor issue and I am extremely happy with my SP2! :)
     
  12. jackh

    jackh Member

    Joined:
    Jan 12, 2014
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    I Have 2 Pro 2's a 512 with the 4300 & 256 4200 both with Type Cover 2's and I have never been able to get or hear Clicking sounds with either no matter what I do!!

    Jack
     

Share This Page

Search tags for this page

microsoft surface making noise when typing

,

no matter what i do my touch cover wont stop making a clicking noise

,

surface typ cover clicking noise