Can't Format my new SDXC 64gb card I bought for my RT

Discussion in 'Microsoft Surface General Discussion' started by guitar1969, Jun 1, 2013.

  1. guitar1969

    guitar1969 New Member

    Joined:
    Nov 3, 2012
    Messages:
    117
    Likes Received:
    8
    Trophy Points:
    0
    I bought a Sandisk Ultra 64gb microSD specifically because I read it was compatible with the Surface RT. My RT recognizes it when I plug it in, but will not let me format it. I have tried all three file types(NTFS FAT and extFAT) but no go with default allocation size. It says "Windows was unable to complete format" when I try. I have tried to do it under Disk management but no go - It shows it as health with 30.99 mb as aRAW file format. I am not sure what to do at this point.

    Any ideas?
     
  2. dvdcatalyst

    dvdcatalyst Guest

    If possible, try formatting the card with your computer.

    I bought a 64GB sandisk (through Amazon) a couple of months ago, and it ended up being bad, and I sent it back.

    With mine, I noticed that the transfer speed (64gb class 10) was considerably slower than my 32GB (class 4) cards, and, when copying MP4 files to it, half my (all working) TV episodes ended up corrupted when I copied them over.
    Formatting the card and copying the same episodes over again resulted in others not working, and ones that didn't work worked.
     

Share This Page

Search tags for this page

cannot format 64gb sd card

,

cant format scandisk ultra 64gb

,

i cant format my sdxc 64gb card

,

is surface pro able to format sdxc card

,

sandisk ultra allocation size

,
scandisk ultra surface format
,
surface 2 cant format sd card
,

transfer speed of class 10 sdxc formatted ntfs

,

windows rt format sd

,

windows rt format sd card