Sdxc not showing up anymore.

Discussion in 'Microsoft Surface Pro' started by Darkelement, Jul 19, 2014.

  1. Darkelement

    Darkelement New Member

    Joined:
    Jul 19, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I tried to transfer some files to my Sandisk micro sdxc card in my pro before a trip. When I woke up, the card was not recognized. Didn't make any sounds when inserted or removed. I tried with regular sdhc cards and they were and still are working fine. I look under device manager when the card is inserted, and it is recognized as a Mass Storage Device (Port.#0005,Hub.#0003).

    I assumed it was the card failing, so I ordered a Samsung micro sdxc card, which arrived today. I installed it, and no response, same as with the Sandisk. I've reinstalled the realtek SD driver twice, and occasionally the Removable device F: shows up on file explorer, but locks up until the card is removed.

    Has anyone encountered this before/heard of this happening before? I'd rather not start fresh if it's not going to fix the problem.
     

Share This Page

Search tags for this page

microsoft kb sdxc not detected

,

sdxc not detected

,

surface 3 sdxc card not detected

,

surface pro 3 sdcx card not recogniced

,

surface pro sd card not recognized