Not had many problems with 'sleep' so far, however...

Discussion in 'Microsoft Surface Pro' started by kayzee, Feb 21, 2014.

  1. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Normally, my Surface runs fine. Goes to sleep when I tell it to, and wakes up when I tell it too... however I've noticed something recently which is a little annoying. I actually have my Surface set to sleep only after 5 hours without being touched.

    It does this fine, but when I wake it, it'll then proceed to continually go back to sleep every 2-3 minutes. It's basically copying exactly what I do at the weekends [​IMG] I just give it a reboot and it starts behaving again. Any ideas?
     
  2. kristalsoldier

    kristalsoldier Well-Known Member

    Joined:
    Feb 24, 2013
    Messages:
    2,314
    Likes Received:
    357
    Trophy Points:
    83
    My Device:
    SPro4
    Change your weekend habits?:LOL:
     
    2 people like this.
  3. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Man... it's never about getting up before 10:00 on a Saturday! NEVER
     
  4. skellington

    skellington Member

    Joined:
    Jan 27, 2014
    Messages:
    59
    Likes Received:
    13
    Trophy Points:
    6
    Maybe this will help? I had the same problem. Not sure what triggers it though it seemed to be related to HOW I woke up the machine. If I used the type cover to wake it up it would do the stuff below.

    -- Machine sleeps after 2 minutes no matter what the sleep time is set to --
    REPRO: Set sleep time to anything greater than 2 minutes, don't touch the machine, observe that it sleeps after 2 minutes.

    SOLUTION: There is a power profile setting called 'system unattended sleep timeout' which is set to 2 minutes by default and will activate the sleep. I don't know why this option exists or why it is hidden by default even though it is relevant, but to make it visible requires a change to the registry. Instructions on how to do that can be found here:
    Power Options - Add "System unattended sleep timeout" - Windows 7 Help Forums

    The link for above can be found in another thread of mine:

    http://www.surfaceforums.net/forum/microsoft-surface-pro/7905-surface-pro-common-bugs-solutions.html
     
  5. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Great thanks, I'll have a look at that.
     

Share This Page