slow wifi using back button?

Discussion in 'Microsoft Surface Pro 3' started by Michael Lovett, Aug 23, 2014.

  1. Michael Lovett

    Michael Lovett Member

    Joined:
    Aug 2, 2014
    Messages:
    99
    Likes Received:
    19
    Trophy Points:
    8
    Not sure if this is an ie issue or an sp3 issue a..but I've noticed repeatedly that initially going to a page is fast, but then clicking back to get to the original page can take many seconds. I see this, for example, with this forum. I'll browse to the post page quickly, then click on a post and quickly be taken to it. But then if I use back, it often takes many seconds for the page to load. However if I click on a shortcut to the posts page I get there very fast..seems like back is doing something weird. Any ideas?
     
  2. agt499

    agt499 Member

    Joined:
    Jul 17, 2014
    Messages:
    151
    Likes Received:
    21
    Trophy Points:
    18
    I've noticed much the same in Modern/Metro internet explorer only.
    Doesn't seem to happen in Desktop IE, Chrome or Firefox.
    In my case the page I'm going back to dims for a few seconds while reloading-is that what you're finding?
     
  3. Gatorswamp

    Gatorswamp New Member

    Joined:
    Aug 22, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Same thing here using the metro IE, go back and it shows the previous page dimmed but takes a couple of seconds to actually load. Sometimes it'll be fast and sometimes it'll be super slow.
     
  4. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    None of these browsers cache pages properly for going back to a prior page. A browser like Maxthon for instance has an option to go back to a cached page as opposed to reloading from the web and it is instant, but of course you may not get the most current information.

    The number 1 culprit for slow page loads isn't ads, flash or any of that, it's Javascript because it breaks up the browsers ability to load multiple threads of data at once. While Metro IE has the cool "swipe back" feature to go to previous pages, the lag is so bad it is basically useless.

    Anyway, this isn't a Surface Pro 3 thing, it's poor browser design.
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,326
    Likes Received:
    1,279
    Trophy Points:
    113
    This is an IE issue not a WIFI issue.

    I posted this on MS support page and they basically refused to acknowledge the existence of the problem and told me I should Refresh. Sometimes support people can be their own worst enemy. although I don't know what's keeping the developers from recognizing the problem and fixing it. Oh, that'd be Project Management and the Product Manager... they must have left it out of the spec and will now have to reopen the code and pay extra to address it.

    This is one of those cases where MS just doesn't make any sense. There are many opportunities where they could invest in Win8x to make it a success but continue to bet the same pony... thinking it will come from behind just watch... I can't believe its that hard to fix if they tried; I can only assume they are not trying for whatever ill conceived reason.
     
    Last edited: Aug 24, 2014
    Michael Lovett likes this.
  6. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,326
    Likes Received:
    1,279
    Trophy Points:
    113
    BTW. Its actually faster to close the browser, re-launch it and go to the page you wanted then to wait for it to do whatever the heck its doing.
     
    Michael Lovett likes this.
  7. drzeller

    drzeller Member

    Joined:
    Jul 29, 2014
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    I use Metro IE as my primary browser while couch surfing. This delay is an incredible pain in the backside. I hope they fix it sooner than later.

    David
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Open up the Internet Explorer Control Panel and on the General Tab and select Browsing History Settings:

    upload_2014-8-24_13-57-54.png

    On the next screen select the radio button as below.... click OK and OK and re-launch IE and it should work much better...

    upload_2014-8-24_13-59-51.png
     
  9. drzeller

    drzeller Member

    Joined:
    Jul 29, 2014
    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    8
    Thanks. I'll give it a try.

    David
     
  10. Michael Lovett

    Michael Lovett Member

    Joined:
    Aug 2, 2014
    Messages:
    99
    Likes Received:
    19
    Trophy Points:
    8
    yep, that' what I'm seeing too. What I'm training myself to do to right click links and select "open in new tab". That way, I'm always leaving the original page open and not having to go back to it. But obviously, this is not my preference :)
     
  11. wmgreenjr

    wmgreenjr New Member

    Joined:
    Jul 30, 2014
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    3
    I get the second or so delay also (MUI IE only)... and I did try jnjroach's method above of not looking for new page updates and still get same delay.

    But to recreate the BIG delay (haven't counted in seconds but seems more than 10 seconds at least), I scroll forward or back and while the screen is still dim I try to scroll up or down and then it goes into this big think mode where I cannot even use the stop button - I either let it run its course or close and reopen. I don't get this BIG delay unless I try to scroll up or down during the 'dim phase.' Maybe others do, not sure??? And I do not get it every time I try to scroll up or down during dim stage; but if I want to recreate it I can do it in just a few tries.

    Maybe it is not a cache issue but maybe MS has a time interval in MUI IE where it is still waiting for more possible touch interaction before fully releasing the page to the browser and then if you scroll up or down during this interval it sometimes freaks out? Just a guess. It does save my delayed up/down requests but does not take action on them until after it quits thinking. Maybe there is a registry setting somewhere that can reduce or eliminate the dim phase?

    Either way the small delay is annoying and the big delay is definitely a break. But for touch I do like the back and forth gestures of MUI IE so I will keep using it (I do sometimes use desktop Firefox in its place though). I haven't done any research on this issue but will search for 'dim phase' issues (lol not sure what else to call it) later in the week. In the meantime, I'll respect the dim.
     
    Last edited: Aug 24, 2014
  12. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Another trick is using the Tracking Filters, as much of the delay is caused by Banner Ads....
     
    annabanana likes this.

Share This Page

Search tags for this page
back arrow is slow
,
back button slow on surface
,
slow back button
,
surface back button very slow
,

surface pro 2 wifi slow

,
why is wifi so slow in surface microsoft