Startup Settings - Impossible to choose an option!

Discussion in 'Microsoft Surface Pro' started by Epo, Aug 21, 2013.

  1. Epo

    Epo New Member

    Joined:
    Jun 17, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I am very frustrated. I tried different methods and non of them works. I hope you guys have a solution I'm not aware of.

    I want to install unsigned driver on my Surface Pro (128GB, Windows 8 Pro).
    I go to Troubleshoot > Avanced options > Startup Settings, and then the “Restart” button as described on this site (and many others).
    However after PC restarts I am not able to choose anything. Simply my keyboard doesn't respond. I connected different one but same thing. Until this moment all works perfectly (and mouse as well). What more, my screen is different than the one from the link (black screen, oldskool DOS view):

    Surface Pro Startup Settings.jpg

    I tried with function keys and with number keys, as well as with num block keys. Nothing.

    My keyboards are not Type or Touch Cover, they are Ligitech K800 and other on regular USB cable.

    I tried on Secure Boot enabled and disabled.

    I'm run out of ideas.
     
  2. Wayne Orwig

    Wayne Orwig Active Member

    Joined:
    Mar 18, 2013
    Messages:
    332
    Likes Received:
    43
    Trophy Points:
    28
    At that point in the booting process it likely has not loaded a USB driver. You need a direct keyboard like the touch or type cover.
     
    1 person likes this.
  3. Epo

    Epo New Member

    Joined:
    Jun 17, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Then the engineers at Microsoft are simply brilliant, superb, genius! Aaaarrrrrr, GOD! What an imbeciles. And no mention it will not work on different keyboard or even using the touch screen (UEFI can that way so why not this part? Eeh).
    Thanks anyway for your reply.
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    You would need to enable legacy USB Support in the Firmware Settings, most of the settings are navigated using the Volume Rocker IIRC...
     
    1 person likes this.
  5. Epo

    Epo New Member

    Joined:
    Jun 17, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I don't see such option in UEFI. Also I've tried volume rockers but no reaction to them as well.
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
  7. Epo

    Epo New Member

    Joined:
    Jun 17, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Unfortunately, whether SB enabled or disabled no option about USB.
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    With Secure Boot disabled have you tried the USB device to see if it is active?
     
  9. Epo

    Epo New Member

    Joined:
    Jun 17, 2013
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Yep, no science nor luck.
     
  10. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Bummer....
     
  11. machistmo

    machistmo Active Member

    Joined:
    Nov 17, 2012
    Messages:
    790
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    Raleigh NC
    My Device:
    Other
    This should be an apple commercial with the Siri voice " Bummer...."
     
  12. lanjoe9

    lanjoe9 New Member

    Joined:
    Feb 3, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Solution!

    I had the exact same problem and was also fuming about the oversight/plain idiocy from the Microsoft engineers, luckily I've figured out a solution.

    Since there is a way to boot from a USB device, in this mode the USB port should be enabled :)P).
    So- a combination of both advanced startup and boot from USB device mode should do the trick:

    1) Do all the steps to get to where Windows describes what "Advanced Startup Mode" means and shows the "Restart Now" button as described here (right before step 3) Windows startup settings

    2) Right after clicking "Restart Now", and before the device physically restarts, press the "volume down" key on the side of the Surface Pro. (This enables booting from a USB drive - and the USB port!)

    3) Once the Surface screen is up you can let go of the "volume down" key

    4) You should be able to use a USB keyboard with the Advanced Startup Settings menu :)
     

Share This Page

Search tags for this page
keyboard not working in startup settings
,
select startup setting on surface
,
serfave 3 missing keytboard option at startup
,
startup option key combintions for surface pro
,
startup settings keyboard not working
,
startup settings on surface pro 2
,
surface pro 2 advanced startup
,
surface pro startup no media present
,
surface startup settings
,

windows 8 startup settings keyboard not working