Surface pen not working. Please help.

Discussion in 'Microsoft Surface Accessories' started by ssps, Nov 4, 2016.

  1. ssps

    ssps New Member

    Joined:
    Nov 4, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I bought surface pen (one button model ) from ebay recently.It connects to surface and click button works as well. But pen is not writing , no cursors on screen. I replaced the battery and nothing changed. Please help.[​IMG] [​IMG]
    I attached image of pen cover. Is it ok? There is only half of metal plate (golden color ). Is it normal ?

    I live in another country so cannot return it back.

    Thanks.
     
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,741
    Likes Received:
    424
    Trophy Points:
    83
    Welcome to the forum

    I don't know if microsoft have multiple versions of the new pen, but that is not what mine looks like

    [​IMG]
     
  3. ssps

    ssps New Member

    Joined:
    Nov 4, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I saw some YouTube videos and the pen they show looks like yours, that's why I asked about it specifically.
     
  4. SeaNurse99

    SeaNurse99 New Member

    Joined:
    Saturday
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I have a Surface Pro 3 and recently got a Surface Pen (one button model) and have the same inside battery connection as hughlle.

    I couldn't get the first pen to turn on; changed battery...still didn't work, so I exchanged it. Now the second pen is not turning on either...is there something wrong with me or the pen? I find it hard to believe 2 pens don't work. I push and hold the top button on the pen for 5-7 seconds, but the LED does not come on or flash. I've reseated the battery, but the pen does not come on.

    Can anyone tell me what I may be doing wrong or is there a step I'm missing?
     

Share This Page