Surface Pro 3 Issues

Discussion in 'Microsoft Surface Help' started by romc14, Jul 22, 2015.

  1. romc14

    romc14 New Member

    Joined:
    Jul 22, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Hey all !
    I just bought my surface pro 3 i5 256gb model about a month ago and it has a few issues I was wondering ya'll could help me solve.

    1st Issue: It gets uncomfortably hot towards the bottom right side of the screen and I just have a few apps and programs open. usually chrome, email and one note.

    2nd Issue: Because it gets pretty hot the fan is always running. It is rarely ever quiet.

    3rd Issue: sometimes when chrome is not working I use internet explorer and when I do my surface pro freezes. I have to close down internet explorer just to get it working again. I've noticed IE takes up almost 200mb of my RAM and all I'm doing is watch a youtube video and have yahoo news open.

    4th Issue: Each time I play "Heroes of the Storm" my surface pro keeps changing the resolution to the resolution I play the game on when I exit the game.

    5th Issue: This is not really a big issue, I don't think but when I'm on certain websites on google chrome black lines appear across the screen when i start to scroll.

    6th Issue: When I watch movies in HD the darker colors and shades look off and do not blend at all.

    I have updated windows 8.1 to the latest version and installed all updated drivers and these problems still persist.
     
  2. malberttoo

    malberttoo Super Moderator Staff Member

    Joined:
    Feb 26, 2013
    Messages:
    2,255
    Likes Received:
    428
    Trophy Points:
    83
    Location:
    Alaska
    My Device:
    SPro3
    HI, welcome to the forum! I've edited the title of your thread, since there actually is a "Surface Pro" device, and you have Surface Pro 3.

    I can tell you from experience, that Chrome is not an ideal choice on the SP3. It is coded in such a way that it forces the processor to run at a higher rate, constantly, and never lets it idle. When most other app are telling it "I don't have any work for you to do since I'm just sitting here doing nothing, so go ahead and take a a break", Chrome keeps it working. So your SP3 runs hotter, and battery life suffers. Also, if you compare IE with Chrome, scrolling is terrible on Chrome. I am an avid Chrome user on my workstation at work, but I only use IE on my SP3.

    Also since you've only had the SP3 for a month and yet have several different issues listed, I personally would recommend you do a full reset, which restores the SP3 back to factory settings. My own brand new SP3 had crazy issues right out of the box, and finally at the 3 week mark, I did a full reset and my machine was practically perfect after that. I just think that they are often buggy when they leave the factory, but have no explanation for it. You'll need to backup your files because you're going to lose everything, and have to re-install your apps afterward.

    Here are the instructions. It's easy and doesn't take very long. https://www.microsoft.com/surface/e...ry/restore-refresh-or-reset-surface-pro#reset

    Regarding #6, it is a common complaint and one that I've made myself as well. I haven't yet seen a satisfactory solution to it.
     
  3. romc14

    romc14 New Member

    Joined:
    Jul 22, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Thank you for your very detailed reply ! i will uninstall chrome and see if it makes a difference, if not i will do the reset like you suggested. Thanks so much !
     
  4. malberttoo

    malberttoo Super Moderator Staff Member

    Joined:
    Feb 26, 2013
    Messages:
    2,255
    Likes Received:
    428
    Trophy Points:
    83
    Location:
    Alaska
    My Device:
    SPro3
    As far as troubleshooting goes, I just think it's a lot faster to get to the heart of an issue and see right away what's fixable and what's not.
     
    leeshor likes this.
  5. romc14

    romc14 New Member

    Joined:
    Jul 22, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    So I uninstalled chrome and it made a world of difference ! Its much more quiet and it doesn't heat up at all ! Thanks so much ! is there another web browser I can use besides IE ? like firefox ?
     
  6. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Firefox works just fine.
     
  7. malberttoo

    malberttoo Super Moderator Staff Member

    Joined:
    Feb 26, 2013
    Messages:
    2,255
    Likes Received:
    428
    Trophy Points:
    83
    Location:
    Alaska
    My Device:
    SPro3
    That being said, if IE isn't working perfectly, I still think you should consider a reset at some point.

    How about first starting with just resetting IE though, before you reset the machine. Open desktop IE, tap the ALT key, Tools, Internet Options, Advanced tab, Reset. This will nuke IE back to factory, so be sure and back up your favorites if you have any.

    IE has been a great experience on my SP3, so I want to see it working well for you also.
     
  8. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,691
    Likes Received:
    422
    Trophy Points:
    83
    Just to play devils advocate... I installed Firefox, and following the Flash player installation, my surfacecran hot and loud.

    Chefs will be chefs, always stiring up the pot..

    I personally just use IE which works just fine fir near everythig i do, and use chrome for specific add-on requiring tasks.
     

Share This Page

Search tags for this page
microsoft surface pro 3 connection problems
,
microsoft surface pro 3 issues
,

surface 2 2015 issues

,

surface getting hot and fans runninm

,
surface pro 3 using 200mb of ram