tablet wont recover or load os

Discussion in 'Microsoft Surface 2' started by Jippo, Mar 21, 2015.

  1. Jippo

    Jippo New Member

    Aug 17, 2014
    Likes Received:
    Trophy Points:
    So this morning I decided to jump on my surface and use it. I was surfing the net on facebook and on a forum then i looked up at the tv then back at my tablet and then it had a light coloured blue screen with no message just all blank. So i decided to leave it and see what it was going to do, 5 mins later still on the blue screen so i thought maybe its just frozen and ill turn it off and then back on again.

    I turned the tablet back on and it came up with a message saying it has found a problem and checking it out and will restart and repair it when i saw that message for the first time i had a glimps and saw some message saying something about a storage issue cant exactly remember what else it said as it went to restart. So it restarts and goes into the automatic repair and does what ever it needs then restarts and goes back to something went wrong again and checks and restarts and goes back to the auto repair and does it all over again. All it does is that and that's it wont do anything else.

    Took it back to where i bought it and they tried to see if they could do anything but nothing seemed to worked and suggested to speak to Microsoft about it. Since they aren't open on weekends i thought i try asking about it in here first to see if anyone has experienced this before.

Share This Page

Search tags for this page

load os microsoft surface


microsoft surface recovery wont load


surface wont load os


tablet dont load os