What's up with the resolution of the internet browsers?

Discussion in 'Microsoft Surface Pro 2' started by spinachpie, Apr 26, 2014.

  1. spinachpie

    spinachpie Member

    Joined:
    Apr 25, 2014
    Messages:
    135
    Likes Received:
    7
    Trophy Points:
    18
    It looks really blurred - Chrome being the worst offender. When I reduce the text size via 'Make Text and Other items Larger or Smaller' to 125 or 100 everything is too small, but when you don't, the text looks blurry and horrible.

    Even I.E. has this issue. Is there an actual I.E. app for surface which will give me decent resolution and text size when browsing? It's really hard for me to read at the moment.

    Thanks
     
  2. jrhillma

    jrhillma Member

    Joined:
    Mar 5, 2014
    Messages:
    55
    Likes Received:
    4
    Trophy Points:
    8
    That is an artifact from changes to DPI scaling in Windows 8.1. If you go in to the display settings and then in to "make text and other items larger or smaller" you can enabled the "let me select one setting..." option and it should resolve the issue. At least it did for me; although I also changed my scaling to 100% from the default (150% I believe).
     
  3. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,107
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Chrome is still using XP GDI scaling and doesn't work well on high DPI Screens. You can disable scaling at the .exe level right clicking chrome.exe and selecting Properties and on the Compatibility Tab check the box that says Disable scaling on high DPI Screens (maybe not the exact wording).
     
  4. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    Make sure that your screen resolution is 1920x1080. I think you lowered your screen resolution by mistake. That is why IE is blurry. Also, make sure you have UNCHECKED "Let me choose one scaling level for all my display". I you have that on, and it's using the old Windows 7 scaling system, which isn't great.

    Once that is fixed:
    Use Firefox or IE. Both support high DPI aware. Text is nice and sharp.
    However, Firefox is not great on multitouch. You can add addons to improve things nicely, but you won't get the smooth super responsive IE 11 experience.
    Some people, like myself, uses both. IE for touch, and when in "laptop mode" I use Firefox.
     
    Last edited: Apr 26, 2014
  5. Judist

    Judist New Member

    Joined:
    Apr 20, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I've been thinking the same thing, good tips here, thanks!
     

Share This Page