Wifi connection takes a while to connect after Reboot

Discussion in 'Microsoft Surface Pro 2' started by cdf3, May 10, 2014.

  1. cdf3

    cdf3 Active Member

    Joined:
    Apr 5, 2014
    Messages:
    188
    Likes Received:
    27
    Trophy Points:
    28
    It takes my Surface Pro 50-60 seconds to connect to my wifi network after Booting Up the device.
    Is this typical?

    I don't have this problem coming out of Sleep Mode. Only if I reboot my device, or Boot Up my device after it has been Shut Down.
     
  2. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Do you have more than one SSID? Mine used to try to connect to the wrong one first which slowed initial connection down...
     
  3. cdf3

    cdf3 Active Member

    Joined:
    Apr 5, 2014
    Messages:
    188
    Likes Received:
    27
    Trophy Points:
    28
    Don't think so. How could I check?
     
  4. DungeonShredder

    DungeonShredder New Member

    Joined:
    Nov 13, 2013
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Canada
    I have this problem as well
     
  5. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Click on connections and see how many you've got. For instance I have my EE's router connection, my AirPort Express 2.4GHz connection and my AirPort Express 5GHz connection. When mine was taking a while to connect, it was automatically targeting the wrong one... all I did was delete my password from all the connections I didn't want the Surface to try and connect to, and now it goes for the only one it can! It's up within a few seconds of boot now.

    Sorry if I used the word 'connect' too much there :p
     
  6. cdf3

    cdf3 Active Member

    Joined:
    Apr 5, 2014
    Messages:
    188
    Likes Received:
    27
    Trophy Points:
    28
    I only have one router. I also have the box checked for it to connect automatically, but it doesn't. I have to manually connect, and it takes over a minute each time
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    You may want to try inputting the IP and DNS info manually into the adapter settings. That should help.
     
  8. cdf3

    cdf3 Active Member

    Joined:
    Apr 5, 2014
    Messages:
    188
    Likes Received:
    27
    Trophy Points:
    28
    It was suggested that I uninstall the wifi driver for the Surface Pro. After doing so, I rebooted and it reinstalled the drivers automatically. It's been working fine ever since.
     
    Last edited: May 17, 2014
  9. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Great to hear it's working again.
     
  10. ronvgs

    ronvgs New Member

    Joined:
    Mar 24, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    The Netherlands
    I had the same probleem.
    Uninstaled the driver and now It Works. Thanks
     
    Last edited: May 21, 2014
  11. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Glad you got this fixed :) but just for future reference, you can have more than one SSID transmitting from a single router...
     

Share This Page

Search tags for this page

surface pro 3 recreate ssid each reboot