What's new

Solved 5GHz Wifi


Active Member
Thanks everyone for your replies. As it turns out, the issue was actually with my router. For some reason it wouldn't allow connections on the 5GHz band. I reflashed the firmware and bingo, now connected to the 5GHz network!

Feel a bit silly now blaming my Surface. Loving it so far.
Good for you! ...both in expanding your remediation efforts outside of the SP3 hardware and reporting back to us on a problem solved.


New Member
I guess I"ll put this here in case it helps any future searchers.

I couldn't connect to 802.11n 5 ghz at home with my Surface Pro 3.

I have a DD-WRT router at home..
I finally ran across a link with for DD-WRT with the Qualcomm Atheros chipset best practices

It said that when wireless mode is set to 'N only' with this software, it is frequently broken. So I changed it back to mixed, and could immediately connect.

I changed my channel width off 20 Mhz to 40 Mhz (I'd only changed that to 20 as part of troubleshooting recommented here), and got reasonable speed.

So turns out it was me and not the Surface also :D

Members online