What's new

Cannot boot from USB


Super Moderator
Staff member
I loomed at Rufus briefly because I didn't really need it I never used it however it has about a billion options IIRC so it might help to specify what worked.

I think the issue with the Win7 tool is it's out of date and doesn't work with UEFI.

I know with the newer Microsoft Media Creation Tool you have to specify 64bit only for a Surface. I have always had good luck with this tool.

There are so e other gotchas like
sometimes other partitions on the USB cause troubles so doing a Diskpart clean on them can usually resolve that. Some manufacturers have other bits in the tables which cause problems.
Sometimes having a micro SD card installed can interfere

There have always been instances where you insert a USB drive and it doesn't show up in Windows and you have to assign a drive letter... not sure of the cause but this appears to be the issue addressed by the post above. Good tip.

The Rufus I used has about 5 options or so. Simple enough that it doesn't even need to be installed, can be run straight form .exe


I simply left all settings as they were, selected the USB drive from device list, browsed for the image using the button next to create bootable disk image, and clicked start. I had previously tried using the windows disk creation tool, and a couple of others but had issues here and there.


and earlier versions of Acronis didn't' play well with UEFI either... although I hear it's fixed I gave up on Acronis and have been using Macrium Reflect.

If your hoping for a one recovery drive fits all solution... you may be OOL.

Using Acronis 2015 on Pro - have used Acronis for years with no issues, but as you said "1 fits all" may not apply anymore.
I may try your suggestion on the Pro - thanks.
Last edited: