What's new

Charging problems

SteveSAPA

New Member
Hi all,

Ive been on this site since buying my first surface (SP2) about 5 months ago but only recently joined.

I have loved everything about it & never had any issues until today.

I plug my charger in & after about a minute it stops charging & the white light turns off. I have to move it around a little bit (left & right) to get it to start charging again. Since I started writing this post it has turned off 3 times.
One issue that I noticed a couple of days ago while I was charging it, the SP2 (near where it charges) & charger connector got really hot. I couldn't even touch it.

Has anyone else had this problem or know how to fix it?
 

GoodBytes

Well-Known Member
This sounds like a you have a faulty device :/
It is normal that it get warm on that area as this is the charging circuit, but not super hot.

Try unplugging the device, and press and hold the vol-up button then the power button, and keep holding. The device will startup and go on the UEFI menu screen, keep holding until it turns off again.

Once it turns off, you can get let go, and now press the power button to turn it on normally. Let it boot into Windows.
Now see if your problem is solved.

If the above does not help, it could be the power adapter, but it could also be the device. Try and have the power adapter replaced under warranty, and if that doesn't help, then it could very well be the Surface Pro charging circuit that is faulty, and need replacement.

If you have a Microsoft store near by, go there and see what they say. If not, call Microsoft surface support.
 

Members online

No members online now.
Top