What's new

Error with Japanese Keyboard


Active Member
Hello everyone, I'd like to quickly explain the issue.

I have a SP2 and I am currently in Japan. To write faster I decided to buy a Japanese keyboard from the Microsoft store online. It arrived and it worked. Well, kind of. What happens is that it recognizes it as an English keyboard. So what I did is I went into the control panel and installed Japanese, but it says Microsoft IME. While on my normal keyboard it says "English --> US Keyboard)" and I write in Spanish, too, on the same keyboard and it says '"Spanish --> US Keyboard"

On the Japanese one, it simply says "Japanese --> Microsoft IME" which is funny because this is a Japanese keyboard made by Microsoft! This keyboard has 109 buttons and the extra keys help with changing between their 3 methods of writing. That's the reason why I bought the keyboard! And they don't work. The extra keys don't work at all while in Japanese Microsoft IME.

I've tried:

* Refreshing (vol up + power)
* Windows update
* uninstalling the device from device manager
* chatting with Surface in both Japanese and English, of course, they couldn't figure it out. I have to talk with them again later.

Any ideas? I'd greatly appreciate it! I would like to have the computer recognize it as a KEYBOARD and not just Microsoft IME. Is it possible? Or how can I get these keys to work before going back to the US!?!? If it doesn't work, I'd return it of course. They're fairly expensive.

Thanks for your time! Kind regards,



  • Screenshot (7).png
    Screenshot (7).png
    14.5 KB · Views: 418


Active Member
Switch to Japanese using alt+ spacebar. If that works, the other keys should work as well. If the don't, right click the IME icon on the taskbar, select preferences and make sure that the right boxes see checked.
One more thing you can do is enter text in hiragana (you have to make hiragana the default input method) then try F6 and check if it converts to katakana. You'll need to hold down the Fn-key while pressing F6.


Active Member
I don't know what I did but I got it finally. I can say that I ran windows update a few more times, I added the keyboard a few more times, downloaded some language packs and then voilà , it worked for some reason. But it's still Microsoft IME. But I guess that's how it's supposed to work.

Thank you everyone for your help

Members online