What's new

Solved My keyboard language keeps changing


On my Surface Pro 3, I have three languages installed for my keyboard. I usually use English, but unfortunately it keeps switching while I work. Changing it back to English is easy, but it keeps switching to those other languages I have installed at random times. I'm using a type cover keyboard, and I don't know what I pressed that caused the switches, but it's getting annoying.

How can I prevent this from happening at random times? Am I just making it happen myself because I accidentally press the keys that switch languages? Exactly which keys on the keyboard am I supposed to press to change the language?


Staff member

It is likely you are pressing a shortcut sequence on your keyboard to change language.
Fortunately, you can modify that sequence.

Go here:
Switch Input Method (Keyboard Language) Using a Keyboard Shortcut



Active Member
Another setting to consider is if you should use different languages in different windows, otherwise when opening a new window it will open it in your primary language.


New Member
Just press "Ctrl" + "Shift" to switch to another language. Alternatively, you may forward to the language icon at the right-end of your task bar and click on it to change. Hope it helps.