What's new

Extremely dim display, can't adjust brightness


New Member
Hi, I have a Surface Pro 2 that I picked up a week and a half ago. It's been working beautifully until this morning. I turned it on and it looks like the brightness is set at about 10%. I removed the Type 2 cover and it jumps back to normal for about 5 seconds then goes back to extremely dim. I've restarted, shut down, tried to adjust the brightness in power settings but nothing works. Any one have any ideas or had similar experiences? I'm hoping it's not a faulty unit. It was the last in store (it was sealed so wasn't a faulty return). It's an 8GB/256GB unit at $999 so I'm really hoping I don't have to bring it back.

As a side note, could be completely unrelated, OneDrive won't sync anymore either. Syncs 10-20mb of over a GB and then just stops. Did some updates screw me up I wonder?


New Member
So I just disabled auto-brightness and it seems to be working ok again. But it seems odd that it just started acting like this today.


Well-Known Member
Shutdown the system, press and hold the volume up button, and then press and hold (while holding the volume up button) the Power button. The sytem will turn on, keep holding both buttons, then go to the UEFI screen, keep holding... then turn off. Now let go the buttons, and press the power button.

This cuts the power of all internal hardware, and turns it back on with the system. See if your problem is solved.
Unsurprisingly I had the same issue: http://forum.tabletpcreview.com/microsoft/63364-sfpro2-adaptative-brightness-stuck-dim.html

I don't really install anything on Windows (I did install VS2013 though, but that was long ago), so it probably was a recent update. Not sure though. Not a hardware problem because I could read the light sensor from Linux without problems.

Eventually it went away on its own.

I had tried everything including turning it on with the "Volume Up + power" combo during 30 secs (which is what MS suggests), to no avail.
The only "workaround" that seemed to work was manually setting the ALSPoints key in the registry. You can find some examples in XDAdevelopers (via the link in my post in tabletpcreview). However, I suggest deleting the ALRPoints key periodically just to check if it's been "magically" fixed (which is what happened to me).