What's new

fix for windows key being stuck on wake up


New Member
Just recently, past two days or so, my surface pro started getting all retarded. Seems like the windows key gets stuck whenever I wake it up from sleep. This is whether I have the type cover attached or not, before wake up, after wake up, dancing around the Surface while waving the keyboard in the air in the sign of a pentagram under a harvest moon. Nothing works except to restart it. Its getting really annoying and happens almost everytime I try to wake it up now. Its embarassing really, *note to MS: You're not impressing all those college kids with discounted macs*.

I read a couple threads on here about the same issue and they suggested all sorts of rituals with the keyboard, hence the dancing and waving. Seems like the only thing that has worked consistently is a refresh of the Surface. I do NOT want to do this...YET. It took me a long time to install all my programs and input all my settings and I really don't want to do it all over again so soon. So is there any fix for this?

My Surface is two weeks fresh, and my first Windows 8 machine. Win8 is bi-polar enough and if two week refreshes is what I have to look forward to I'm going to sell it and just go to an Android tablet/laptop combo. Nice hardware, but the software is half-baked, brilliant at times sprinkled with lots of WTF moments.
Welcome to the forum. Short of a refresh you might want to clean screen (assuming you mean the bezel button since sometimes the keyboard isn't attached). If you mean the keyboard Windows button you might want to try cleaning the contacts of the keyboard and the Surface.
Sorry, should have clarified, lol. I meant the windows key, like on the keyboard but its stuck on the computer. The keyboard itself is fine, but windows thinks the windows key is pressed. This is verified by opening up the onscreen keyboard during the login screen and it is "pressed"
ahhh...WTF! now my freaking documents folder is "gone". Other than updating I haven't touched any settings since last using it. This is the error message I get when clicking on the Documents Library:

"Documents.Library-MS" is no longer working.
This library can be safely removed from your computer. Folders that have been included will not be affected.

My Docs is still there on the C drive thankfully and deleting and creating a new docs library is just fine but good god! this is getting annoying as $#!+.
Last edited:
Haven't contacted them yet. I was hoping to resolve the problem without their assistance. In the other thread it looks like they were just told to refresh the system.
I was experiencing the issue 3 days ago out of the blue, and found this thread. Tried many things and even did a full recovery, but wasn't able to fix this issue. I brought it into my local Microsoft store, and they couldn't figure out how to fix it, so they swap me a new system and that resolves it.

Speaking of which, Microsoft store's service was amazing! They swapped a brand new in box system for me instead of giving me a refurb. They even let me keep my old charger and pen. I will be coming back for more future Microsoft products for sure! Back when my gen 1 iphone broke, I was gotten a refurb phone, and the refurb broke in 2 months with gentle use.
I had this issue on another win 8 tablet about a month ago and did this and it worked. The issue effected picture folder, document, music so I did this to all of them and it worked. to fix this problem you need to delete the misbehaving library first. Deleting a library does not delete the content of the folder. To fix this problem, open Windows Explorer, right-click on the corresponding library and choose Delete. Click Yes when asked for confirmation.Then, in the navigation pane of Windows Explorer, right-click on Libraries and click Restore default libraries. This recreates the library that you just deleted. This option will only restore the default libraries that came with Windows 7.