What's new

Micro SD Card Problem

Padi

New Member
Have a problem with SanDisk Ultra 64GB Micro SD XC I card. It is disappearing like Harry Houdini from SP3, after that it has to be reinserted again to work for while and vanishing again from the system. Do not have any problems with Kingston 2GB Micro SD card. 64 GB card is not loosing any data. Uninstalled and reinstalled drivers, reset SP3 to factory settings, no fix.....
 

ipaq_101

Active Member
If there are no problems with the 2GB card then the problem most likely is with your 64GB card. Is it a new card? Did you try to reformat the card and see if that fixes it? If I had to guess, I bet it's a defective card, one of my friends had that happen in his Samsung phone, his card worked fine for a year and then it just stopped. I tried my card in his phone and it worked fine, but his card stopped working.

Cards go bad all the time, I say try another card and see if that has the same problems. I have a 64gb sandisk ultra and haven't had any issues.
 
OP
P

Padi

New Member
It works fine in my Asus laptop in SD adapter card ?????????? On my way to Costco for return....
 

malberttoo

Well-Known Member
It works fine in my Asus laptop in SD adapter card ?????????? On my way to Costco for return....

Stranger things have happened. I've had USB thumb drives that all of a sudden would only work in one machine, and SD card that did what you're describing.
 

chrsb

New Member
Had the same thing happen to my 64gb card, it would have to pull it out and reinsert it to work. It was brand new sandisk ultra class 10 . Bought a 128gb for $100 and it works fine.
 

fonzman78

Active Member
I have a SanDisk Ultra 64GB card that I used in my SPro2 and now have in my SP3. When I inserted the card the first time, it would not read it. I had to restart and then it saw the card. This was on day one. I've had no problems since. I have my music and movies on it and use it daily.
 

leeshor

Well-Known Member
Stranger things have happened. I've had USB thumb drives that all of a sudden would only work in one machine, and SD card that did what you're describing.

It has happened to me too. Took a while to realize it was the thumb drive. A real head scratcher.
 

mikeeike

New Member
If the SD card works fine with a Micro SD to SD Adapter connected to an SD to USB adapter plugged into the USB Port, that is further evidence that there is a design or manufacturing defect with the micro-SD Ports on the Surface, something that a Microsoft Store employee acknowledged to me. Only solution is to do a swap for $500 or buy a new machine. OUTRAGEOUS!
 

Members online

Top