What's new

microsd card problem

I am having the same problem of disconnection / going offline of my 64GB Kingstone card.
No problem regarding mismatch of size/thickness of the card vs. the surface slot unlike SD brand reported above.
The disconnection mainly occurs when logging in to windows.
Works for some minutes when plugged out & in again.

--> Did we evolve towards a potential solution since the last response to the threat?
Has Microsoft acknowledged the (card reader) issue?
I have a SanDisk 128GB MicroSD. Have had it in the Sp3 for 2 straight weeks now and not one instance of what you all are describing. Its bee a champ. The first thing I did when I inserted it was to reformat in NTFS. As a matter of fact, I think it asked me as soon as I put in the card...
I am having similar issues with a 32 GB Kingston card so I don't think it related to being SanDisk or 64GB. It seems to happen when I attempt large file copies. It is formatted FAT 32, I wonder if that could be part of the problem.
I get error messages saying that there is a problem with the card and when I run a drive repair no errors are reported. You can see in Windows Explorer that the card vanishes for a while then reappears.

It could be a speed issue or perhaps a memory leak, peculiar to FAT32 hopefully. If I restart the computer, copying goes well, for a few hundred MB, and then the problem start again.

When I finally get everything off the card, I might try formatting to NTFS.
I tried reformatting to NTFS but only a Quick Format works. If I try a Full Format, it goes offline again. If I try to mass copy the files back onto the card after a Quick Format, it also goes offline. Will try reformatting on another computer when I get home. It is starting to look like either a corrupt micro SD card or a bug to me.
Well, I am pretty sure that it is a problem with the SP2. On a "normal" Windows 7 computer, I had no problem with a full NTFS reformat but when I put the card back into the SP2 and tried to bulk copy files onto the card, it went offline immediately. The same bulk file copy to the card worked on my Windows 7 computer.
Last edited:
Well the problem seems to occur with various brands of SD card and Micro SD card in either the Micro SD slot or USB port. The common denominators seem to be the SP2 and bulk file copying. Whenever you do this the device will almost always go offline before the copying is complete. The same process with the same card and reader works reliably on full PC. I was hoping to use the SP2 TO manage image files from my camera whalebone the road, but if file copying is so unreliable, I am having second thoughts. Very disappointing really
The only thing that I have gotten from this thread so far is that I am not alone. I doubt that I will be interested in the Windows Surface next time around, too many quirky software and hardware problems not to mention the discontinuing of model specific adaptors.