What's new

New update still no Ad Hoc

dmibe

New Member
After today's "wifi" fixing update...we still have no Ad Hoc capabilities or ICS. This is completely broken and MS refuses to acknowledge it and Marvell forwards you to MS.

I'm not even trying to create ghetto tethering, I'm just trying to adhoc connect my tablet to my freaking camera. Such a simple action that worked on previous Surfaces is now rendered futile with SP3. I simply don't understand.

For those unknowing, running "netsh wlan" commands to create an adhoc network on SP3 results in "The hosted network couldn't be started. A device attached to the system is not functioning."

The way to fix that error is to enable connection sharing in your device properties...the only problem is that because ICS is disabled (and can't be re-enabled), your device properties doesn't have a sharing tab.

If anyone knows how to tweak drivers or manually force this on, please let me know.
 

ctitanic

Well-Known Member
The scenarios that you are describing is not a common one. I don't know up to what point Microsoft would be interested in spending time and resources in "fixing" something that "is not broken".
 

wertzius

Member
It is broken! Every other device is able to do this.

It is able to do Miracast, which is in fact a form of ad-hoc networking.
 

rabilancia

Member
A couple of years ago I had an HP TouchSmart laptop that had nothing but problems with its internal WiFi adapter. I purchased and started using a separate USB WiFi adapter. I simply disabled the internal adapter and never looked back.

FWIW, here's the device I used:
http://www.amazon.com/gp/product/B008IFXQFU

I realize the downside of "wasting" the single USB port in the SP3, but I wonder if such an approach might allow AdHoc connections?
 

bluegrass

Well-Known Member
My camera has wifi but I have never have tried it. It's much faster to transfer video & photos by putting the camera SD card into the Surface and grab the files that way. A lot of times there's multiple ways to skin a cat. Sorry nobody has a simple answer to fix your problem. Sometimes it's a matter of do you feel you need to throw the baby (Surface) out with the bathwater (adhoc).
 

Jimmy Lam

New Member
I'm having the same problem, just trying to get the surface to connect to my canon 6d, So that I can shoot tethered, I have success using a router, but the connection is so slow, just wanna try ad hoc to see if speed improve, and see if I can have them connected while outside.
So disappointed, I looked into Ms website for support, but can't even find an email address, the chat box is waiting forever, will try to get to them latter and have them concern about the problem!

PS, I will try using my phone as hot spot so that I can get surface to connect to camera thru the phone, when outside, anyone tried it before?
Did anyone tried using 3rd party software to create an ad hoc network on surface 3?
 

Bandito

Active Member
This is an SP3 problem! Windows 8 and 8.1 do support this feature, as does Windows 7. The SP3 is the only machine that I've encountered that cannot do an Ad Hoc connection via a virtual wireless adapter. Even the SP2 supports this.

I was told by Microsoft Surface support personnel that they are aware that this feature doesn't work, but don't know if they will be correcting the issue or not. It was available in their early WiFi drivers for the system, before release, but was removed because it was not reliable.
 
Search tags for this page
ad hoc network in surface pro 3

ad hoc network on surface pro 3

ad hoc windows 8 microsoft surface pro
adhoc connection surface pro 3
adhoc network a device attached to the system is not functioning
adhoc surface pro 3 windows 10
create ad hoc on surface pro 3
create ad hoc surface pro 3

surface pro 3 ad hoc network

surface pro 3 adhoc network

Staff online

Members online

Top