What's new

Solved Periods of being very unresponsive -Two finger scroll to blame?


Hi, in the last few days my SP3 has had quite a few bouts of extreme unresponsiveness.
When it occurs the touchpad lags by 3-10 seconds, and screen touch is also conked out.
It tends to start in chrome or firefox (but that's also where I spend a lot of time so may not be meaningful), and it seems to choke all apps including File Explorer while it's happening.
App switching via Alt-tab seems perfectly normal though, so the window manager process it unaffected.
After 5 or 10 minutes it comes right and then operates fine until it does it again hours later.

The strangest thing is that it makes a weird chirp/plop sort of sound from the speakers when using the touchpad or touchscreen in this state - it's like a proper system sound, but I have the sound scheme set to none, and it doesn't seem to match any of the standard windows sounds.

I can't find anything corresponding in the event logs: has anyone had a similar experience, or have advice to offer?

Edit : Just after posting I had it hit again, and at this stage I can trigger it 100% reliably with a two-finger scroll on the touchpad - in Chrome, Firefox, Control Panel (Old Windows style), Libreoffice, Komodo Edit. But NOT in Edge, IE, Notepad++.

Touchscreen scrolling in everything is fine, as is PageUp/Dn via keyboard, but right at this moment in time I can trigger a total cursor freeze (complete with chirping noise) in any of the apps listed in bold above any time I try touchpad scrolling.
I know apps are built with different toolkits, and apart from Control Panel I think many of the problem apps might use GTK, but have worked fine until the last week.
Last edited:


Update : I think I've tracked it down to a bug with the updated version of AltDrag, which lets you move windows by holding the Alt key and dragging any part of the window (as in most Linux desktops).

AltDrag is awesome for Windows, don't be put off by my issue : just make sure to disable Scroll Inactive Windows and my problem disappeared.