What's new

Slow Wi-Fi Download Speeds, but Upload Speeds OK?

Turbo4AWD

Active Member
Ok, it literally just happened to me just now. I was reading this thread and decided to run the SpeedTest app by Ookla to see if I was experiencing the slow 20mbps download issue when I should be getting 250mbps. I ran the test and the needle was pegged at 20mbps throughout the test. I clicked the wifi icon in the system tray after the test completed and I clicked the square blue "wifi" button and it went black signifying Wifi was just turned off on my Surface Pro 6. I waited 15 seconds and clicked the wifi icon in the system tray again and click the (now black) wifi button and it turned blue. My wifi then connected successfully to my home network. I go back to the SpeedTest Ookla app and click "Go". IMMEDIATELY the needle is pegged at 230mbps+ and completes the test. I attached a screenshot of the test results below.


1589936165441.png
 

sk3els

New Member
Hm.. I do appreciate the replies, but I tried the strategy and, well.. see below. I found using my laptop which is getting 50 Mbps (right behind me) as a hotspot is the best way to work around it right now. Doesn't that imply that my SonicWall / Unifi AP doesn't like something about the SPs Marvell NICs? If it's perfectly capable of getting 20-30 Mbps download when connected to a hotspot connected to the same network?

1589936843021.png
 

Artie-1

New Member
Not sure how related this is to turning your wifi on/off. My wifi is extremely slow compared to my cell phone. Phone gets 400+ mbps with speedtest.net, Surface Pro gets less than 100 mbps. I went through all the Microsoft recommendation with no change. I went looking for a new driver from Marvell and found none.

My current driver is:
Provider: Marvell Semiconductors, Inc.
date is: 1/21/2020
driver version: 15.68.17018.116

So I thought I'd try going back to the first driver shipped with my Surface and low and behold, my wifi got to 365 mbps. So I then picked a prior driver (date:2/9/2017, ver:15.68.9114.29) and it too worked well. So apparently the 15.68.17018.116 driver slows things down.

How to rollback your driver:
1. select Windows Key and x
2. select Device Manager
3. expand Network adapters
4. right click on Marvel AVASTAR Wireless-AC.........
5. select Properties --> Drivers --> Update Drivers
6. click on "Browse my computer for drivers"
7. click on "Let me pick from a list of available drivers ........"
8. make sure "Show compatible hardware" is checked
9. the driver at the top of the list is your current installed driver, so select a driver below it, click on Next, driver will install, click on close.
note: Before you reboot, you can see the driver version by repeating steps 4 & 5 above.
10. reboot to activate

Hope this works for you as well.
 

Turbo4AWD

Active Member
I ended up getting ANOTHER firmware update after this as well as display and wifi drivers. See if any of those updates help resolve your issues. It worked for my Surface Pro 6 upload speeds.
 
Search tags for this page
microsoft surface network bandwidth
network speeds slow on ms surface 5

nu vot

slow downloads on surface pro 7
surface 6 slow wifi
surface device connected to wifi but so slow
surface dock slow download fast upload
surface pro 7 slow internet speed
surface pro 7 wi-fi slow upload
surface pro nic driver slow

Members online

No members online now.
Top