What's new

SP3 doesnt really shut down

i am using a Surface Pro 3 with Type Cover 1 and a external mouse on USB.
I recognized that sometimes, when i shut down the SP3 with the charms but, it isnt really shut down. I can track this by clicking on the start button at the Display and it vibrates. I can only start the SP3 again with holdin down the power button for about 10 seconds.
In the reliabitilty index i can see an unexpected shutdown.

Solution Center Shows there is a solution, but when i click on "Show solution" i get the following error (of course my Internet is working ....)

This solution could not be downloaded
Most likely causes:

  • Your computer was unable to download the solution at this time. Check to make sure your computer is connected to the Internet, and then try to download the solution again later.

Primary Analysis
Crash Dump Analysis provided by OSR Open Systems Resources, Inc. (http://www.osr.com)
Online Crash Dump Analysis Service
See http://www.osronline.com for more information
Windows 8 Kernel Version 9600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 9600.17085.amd64fre.winblue_gdr.140330-1035
Machine Name:
Kernel base = 0xfffff800`09215000 PsLoadedModuleList = 0xfffff800`094df2d0
Debug session time: Sat Aug 2 09:59:34.666 2014 (UTC - 4:00)
System Uptime: 0 days 4:38:32.613
* *
* Bugcheck Analysis *
* *
A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
Arg2: ffffe000b6c035c0, Physical Device Object of the stack
Arg3: ffffd001a5abe930, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
Arg4: ffffe000b8f231a0, The blocked IRP
Debugging Details:
TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2
IMAGE_NAME: ntkrnlmp
MODULE_NAME: ntkrnlmp
FAULTING_MODULE: fffff800b83e5000 raspppoe
DEVICE_OBJECT: ffffe000b6c88050
DRIVER_OBJECT: ffffe000b8367290
IRP_ADDRESS: ffffe000b8f231a0
ffffd001`a5abe8f8 fffff800`09411c1e : 00000000`0000009f 00000000`00000003 ffffe000`b6c035c0 ffffd001`a5abe930 : nt!KeBugCheckEx
ffffd001`a5abe900 fffff800`09411b3e : ffffe000`b5a6a8f0 00000000`ffffffff 00000000`00000000 ffffffff`00000003 : nt!PopIrpWatchdogBugcheck+0xde
ffffd001`a5abe960 fffff800`0926e810 : 00000000`00000004 00000000`00252ab8 ffffd001`a5aaa180 ffffd001`a5aaa180 : nt!PopIrpWatchdog+0x32
ffffd001`a5abe9b0 fffff800`0936caea : ffffd001`a5aaa180 ffffd001`a5aaa180 ffffd001`a5ab62c0 ffffe000`b7916880 : nt!KiRetireDpcList+0x4f0
ffffd001`a5abec60 00000000`00000000 : ffffd001`a5abf000 ffffd001`a5ab9000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a
FAILURE_BUCKET_ID: X64_0x9F_3_IMAGE_ntkrnlmp
BUCKET_ID: X64_0x9F_3_IMAGE_ntkrnlmp
Followup: MachineOwner


Active Member
In order to make things a bit clearer, let me just confirm what you're seeing. You want to power off your SP3, so you open the Charms menu, select Settings, then the power icon, and from the pop-up you select Shut Down. The computer appears to shutdown, but if you later touch the Windows icon on the screen, you get the vibration from the SP3, but the screen doesn't turn back on. Is this correct?

When you shut down the SP3, do you see the Windows shut down screen where is logs you out and then says that it is shutting down? If not, then it's not getting through the actual shut down process. If it does go through this process and isn't actually shut down, that's a very strange and unusual occurrence.

To troubleshoot further, the first thing that I would try is to remove the keyboard and mouse and see if the SP3 powers down normally with nothing attached. If it does, then you can try each peripheral in turn to determine which one is causing the issue. If it still doesn't work and you are current on all updates, then you may need to refresh your Windows installation.

The unexpected shutdown message should be because you held the power button down to force a reboot, so I'm not sure that that really tells us anything about your issue.

Let us know what you find.


Thanks for your answer. I will ask your questions:

* The computer appears to shutdown, but if you later touch the Windows icon on the screen, you get the vibration from the SP3, but the screen doesn't turn back on. Is this correct?*

YES, Screen dose only turn on when Pershing power button for about 10 seconds.

*When you shut down the SP3, do you see the Windows shut down screen where is logs you out and then says that it is shutting down? *

YES, i See the shut down Screen.

I have done a factory reset yesterday, but today the same issue. But it is not always when shutting down, only a few times.

Thx for your answer again.


Active Member
I created a shortcut on the desktop using this: %windir%\System32\shutdown.exe /s /t 0

See if this shuts it down.


first do not hold down the power button unless u want to do a hard reset.

second, sounds like u have not loaded Windows 8.1, you will find it in the microsoft store (green charm/icon) and not in windows update.

third, if you have 8.1 then go to power options in control panel, chose what the power button does, and under shutdown settings disable "turn on fast sartup"
Last edited:


Well-Known Member
Of course he has win 8.1 as he's on SP3, what might be happening is he is going in to hibernate instead of shutting down, then by holding the power button he reboots... maybe he has to change the settings in the power control to the proper shut down procedure... but why shut down when you can just press on the power button and close the type cover and then when you're ready to work on the SP3 just press the power button and it will open up.


New Member
My SP1 has exactly this issue. It doesn't happen all the time but every so often it will appear to shutdown but then the Windows button on the device will still be active (it provides haptic feedback) and the only solution seems to be holding the power button until it restarts.

Sometimes at that point (i.e. restarting after a failed shutdown) I also get a startup error that causes an attempted 'automatic repair'. The repair fails but restarting the device again gets everything working as expected.

As this seems to effect the SP1 and SP3, and the further issue with the 'Automatic Repair' seems to effect other OEM devices as well, I'm starting to think this might be a problem with Windows 8.


Hi and thanks for all answers.
Of course i have Windows 8.1 n i have installed all updates including last firmware update 7/16/14.

Since my post here i have shut down my SP3 3 times and hadnt the error. But i didnt change anything. I have read a lot that fast boot could be the problem, but every SP3 has enabled it so i dont know why i should disable it ;)

I will watch further and if i got new errors i will look for them and post them here. Perhaps i find a solution or - even better - problem is solved ;)

Thanks again to all!


To me, it sounds like you're working too hard and going about it bassackwards.
I have no problem actually shutting down my sp3, and you don't need to go through Charms to do it. In the far upper right of the Start screen, just to the left of the Search icon is the Power Options icon. Click it and you have 3 options, one to Shut Down.
Simple and works for me.


Another way to shutdown is to press and hold the Power button for about 5 secs and a shade will drop down that you can then drag to the bottom of the screen to initiate a shutdown.


And again ...


Unexpected shutdpw
05.08.2014 07:27
Eine Lösung ist verfügbar.
Problemereignisame: BlueScreen

Code: 9f
Parameter 1: 3
Parameter 2: ffffe0017febd690
Parameter 3: fffff801c760d930
Parameter 4: ffffe001860395c0
Betriebssystemversion: 6_3_9600
Service Pack: 0_0
Produkt: 256_1
Betriebsystemversion: 6.3.9600.
Gebietsschema-ID: 1031
Weitere Informationen über das Problem
Bucket-ID: 0x9F_3_UNBIND_PROTOCOL_IMAGE_ndis.sys


Hi together,
because i had sometimes problems with shutting down (while fastboot enabled in the energy options) i tried something and perhaps it is a good tip.

I deactived fast boot in the energy options
Shut Down
New Start
Enabled it
Shut Down
Then i went into BIOS while holding down + and power
In the bios i set
- Trusted Platform to DISABLE
- Secure Boot Control to DISABLE
- Configure System Boot to "SSD ONLY" (before: Network->USB-SSD)

Now Windows is starting 2-3 seconds faster for me