What's new

SP3 Power Adapter USB Port issues? Stops Charging?

Ben Freedman

New Member
Howdy...

Proud new owner of an SP3. For the first time tonight I plugged in my Galaxy Note 3 Phone to the SP3 Power Adapter's USB charging port...

All of a sudden, the screen on my SP3 started cycling from dim to bright every 10-15s or so. I deduced that while the phone was plugged in to the power adapter, the surface kept going from charging to unplugged to charging to unplugged... as if I was popping the power cord in an out every 10s or so....

Upon unplugging my phone from the power adapter, the SP3 went back to charging with no issues... It appears I can replicate this any time...

Has anyone else seen this behavior? Is the power Adapter's USB port really that underpowered?

Thanks for the help!

Best,

Ben
 

r0b123

Active Member
I have not seen this issue. I've charged 2 of my devices, both with different amps. The first with my HTC One phone, and the other my iPad mini. Charging both I wasn't able to repro your power/charging issue.

I suspect it could the power adapter. Maybe if you have a friend/family with a charger and verify the issue. Or stop by the store where you bought it and see if they can help.
 
I basically have the same problem. If I plug in something to charge into the USB port on the power supply my SP3 stops charging. At least the device keeps charging. I can confirm this is not supposed to happen. I had my SP3 replaced and the new charger charges both my ASUS Note 8 Windows Tablet and SP3 simultaneously. At least I still have a second sort of working charger.
 

Members online

No members online now.
Top