What's new

Strange audio problem! Not recognised but can force it...


Well-Known Member
Hi this has happened a couple of times now...

Basically power on, open Groove and try to play a track - What happens is it quickly skips around 20-30 tracks and eventually says it cannot play due to no audio device found. I tried another source (YouTube) and the track would play, but there was no audio outputted.

So I tried outputting to a different source, my Bluetooth connected amp - No problem. Then, with it still playing I changed back to the Surface speaker, and it played! But when I skipped to the next track, it once again done the same as above and failed.

Replicated this a few times after rebooting the Surface. I did however then run the 'Surface Diagnostics Toolkit' which didn't fix it, but after rebooting again after that had run, Groove seemed to act normally (that does include installing any Windows Updates that were pending - Of which there were a few, that I couldn't otherwise find a way to force to install)

When it was in its broken state I checked the audio device in control panel and it appeared fine, and tried to update the driver but it told me it was the latest version anyway.

That might be the end of it, but I shall try again tonight. Anyone else experienced this?


Staff member
A casual search shows that Groove has had track-skipping troubles in the past (2015-2017), but you may have discovered that it has started again.

I use Groove occasionally for a very large MP3 collection. No troubles (Version 1809).


Well-Known Member
I'm guessing the track-skipping is just due to it not finding an audio device to playback through though, as I mentioned audio wasn't working from anything, not just Groove. The only similar problem I've had in the past was a couple of times my SD card wasn't recognised, but in those instances I just ejected and put it back in. This time though the SD was definitely being found as I accessed it through Windows Explorer.