What's new

Surface 3 not working on 5Ghz wifi

remking

New Member
I have two Surface 3's both connecting to a Virgin Media router. One of them connects fine on the 5gig connection but the other will not. It says that it is connected but the Internet performance is simply not there. It works fine e on the other connection in that router which is 2Ghz. The other surface works fine on both. Any ideas? Both running Windows 10. Is it possible that one of them has a hardware problem on the WiFi part?
 
OP
R

remking

New Member
Welcome to the forum

Have you applied every possible update from Microsoft?
Thanks for the welcome. It is set to automatically update so, assuming that picks up everything, then yes. I also uninstalled the drivers for the network card and reinstalled - checking they are the latest.
 

leeshor

Well-Known Member
I would actually check it to be sure. Is there any difference in the security software used on the systems?
 

Turbo4AWD

Active Member
I think maybe there is a firmware update that would solve the issue. Also, try to manually check for updates once or twice and see if maybe something was missed. Otherwise, this sounds like a router issue. As though the router isn't enough to handle the number of devices trying to connect to it.
 
OP
R

remking

New Member
Here is an update. By the way, thank you for your help so far guys. Really appreciated. I have checked firmware on both machines and they are identical. "Invalid IP configuration" was in the log against my 5Ghz connection on the one that is playing up. I connected the dodgy one to the 5Ghz connection - no internet but - I was able to connect to it from my other Surface and file transfers were fast between machines. This was through the router. I tried turning off the windows firewall and this made no difference. I checked the filter list on the router and there was nothing suspect. I'm thinking that this is unlikely now to be a hardware problem else peer to peer would not have worked via the router.
 

leeshor

Well-Known Member
Did you uncheck IPv6 for the WiFi? See if that helps. You may indeed have a hardware problem.
 

DALEcz

New Member
I was just posting this in another thread (sorry for the double post, but it might help):
Well I was fighting with a similar problem recently with the connection via 5GHz .
Firstly it didn't see the 5GHz wifi at all (my main notebook and cellphone without problems) - I found out that it doesn't work when the channel is set to 149 or higher numbers (router (TPlink N750) was set to Auto and the channel was 153). After changing this, the S3 could connect, but the speeds were incredibly slow - webpages were loading for couple of minutes or didn't load at all. I found that it acts that way if the bandwith is set to 40MHz, after manually changing it to 20MHz the speed really improved (11a - 23/23 Mbps; 11n - 80/90). In the case of 11n it is very close to the cable connection. The 2.4GHz worked well all the time - everything set to auto, the speeds were bit slower than in the case of 5GHz.
So maybe you can try to fiddle with the router settings as well?
I didn't try to change the drivers to older ones, so I don't have to repair it after every upgrade, but some people reported that it helped them.

Does anyone have an explanations why my S3 acts that way when connected to 5GHz wifi? Any suggestions? At all the settings tested, even when the S3 didn't connect or was very slow, my computer and cellphone didn't have any problems...
 

GreyFox7

Super Moderator
Staff member
Try the SP4 fix
  1. Run Regedit.
  2. Navigate to the following path: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\mrvlpcie8897
  3. Find the item labeled "TXAMSDU." Double tap and modify the value from 1 to 0
  4. Restart the machine
My S3 is already set to 0 ... IDR if I changed it at some point in the past or not. :)
 

stammie

Member
I've never had any problems with my Surface 3 and the 5GHz range, I definitely haven't changed the setting but mine is on the 0 value that GreyFox7 has suggested.
 
Search tags for this page

5ghz wifi not working on surface

5g not not working surface pro 3
surface 3 5mhz
surface 3 wirless not working
surface 3 wlan 5ghz
surface 5g wifi
surface pro 2 wifi 5ghz not working
surface pro 3 not connecting to 5ghz wifi
surface wifi 5g connection problem
surfacebook 3 no 5ghz

Members online

Top