What's new

Solved Surface Pro 2,3,4 Miracast Problem


New Member
I had hell getting it working and there was almost no information. Just posting this with hopes that it will save someone some time.

If changing your display drivers doesn't fix your miracast problem (If the miracast device and your computer both show that you're connecting but it times out) then this will probably fix your problem.

I have no idea why the service doesn't have an exception but it doesn't. I checked on my sony laptop (fresh install of windows 10, not an update) and it is in fact in there so maybe this is just something that microsoft distributed in their surface builts?

For some reason my SP3 does not make an exception for C:\Windows\System32\WUDFHost.exe which is the service miracast connects through. Its odd because I have a Sony Vaio Flip laptop that came with windows 8 as well and I have no problem connecting with it.

So the long story short you need to go to windows firewall and make an exception for the service. I am going to recommend that you also change the type of network. I'm not aware of any exploit but you never know if one will be made available so I don't want to allow traffic through just any network. Here are the quick steps:

To add the exception to Windows Firewall (You might have to do this with any other firewalls, though I won't know the steps. If you're here you know how to google and I'll trust you can figure out how to add an exception to your firewall).

For Windows firewall: Open the setting menu and search allow an app through windows firewall, click on "Change Settings" then browse. Add copy and paste C:\Windows\System32\ into the folder and then scroll down to WUDFHost.exe.

You will need to click on Details and add the network types. I strongly recommend that you limit it to private networks and then follow the second part of this which will change the network from public to private.

Before you do this you will need to disable your firewall momentarily, just make sure that you reenable it. (Again, you're here so I trust you can disable your firewall or go here:http://bfy.tw/7mgu

swipe from the right

Then click on network settings. Go all the way to the bottom the Network and Sharing center.

At this point hit the windows key + P and connect to the device, make a note of the network that appears. When you've done that open a command prompt window and run secpol.msc

If you get something about already being defined for another app in the store don't worry about it.

Click on Network List Manager Policies

Find the network that popped up in the network and sharing center when you connected to the device. It should be something like "DIRECT<blahblah>-YOURCOPUTERNAME". Double click on it, go to the Network Location tab and select private. I would go ahead and select user cannot change... (out of an abundance of safety) close that, close everything else and reenable your firewall.

Rock on with your bad self with your 65 inch display...

Hope it helps.



New Member
Brilliant. Thanks for posting this. Over a year of not being able to get it working and it's that simple.


New Member
I resume this thread because I have problems using miracast on a surface pro 2.
I'm trying to connect from surface to a wireless display, surface is updated to last windows 10 Creators Update stable version (no insider).
I can find the wireless display in the list, I click project to screen, then it seems to connect but it times out.
I hoped to find a solution following this guide but it doesn't work, as before...
Is there any other idea or trick to test in order to solve the issue ?
Thanks very much!!


New Member
Thanks very much Mike.

I have been looking for a solution to this problem for months. I also have a Windows 10, Miracast-compatible HP laptop that connects to our brand new TV with no problem, but the Microsoft Surface Pro 2 does not, even though they 'see' one another when attempting to connect.

Before trying this solution, a question enters my mind - namely, why would this firewall exception be required on a Microsoft Surface Pro 2 when I do not see this exception listed on my HP laptop that connects properly every time?

Any day I learn something is a good day! Thanks.


New Member
Thanks very much Mike.

I have been looking for a solution to this problem for months. I also have a Windows 10, Miracast-compatible HP laptop that connects to our brand new TV with no problem, but the Microsoft Surface Pro 2 does not, even though they 'see' one another when attempting to connect.

Before trying this solution, a question enters my mind - namely, why would this firewall exception be required on a Microsoft Surface Pro 2 when I do not see this exception listed on my HP laptop that connects properly every time?

Any day I learn something is a good day! Thanks.


New Member
The more I think about this, the more I question things, namely:
  • Although I am seeing numerous comments and a couple of user-suggested solutions without explanation of why the suggested solution was deemed necessary, with such a large number of users suffering Surface Miracast problems, why hasn't some Microsoft expert addressed this issue with definitive answers?
  • For example, several users have suggested it works if one purchases and adds a Microsoft Wireless Display Adapter to the TV, but I have not seen any explanation of why that would be required when the TV is already Miracast-compatible and computers other than a Surface connect effortlessly to that TV.
  • Another user suggested that the problem lies with the Surface NIC being a Marvell chip, not Intel, but surely Microsoft would not design and sell a product that is reportedly Miracast compatible but in reality isn't, would they?
  • Another user commented that certain (all?) TVs have whitelists that do not include much in the way of Windows support. Is that even possible? Whitelists I am familiar with are typically used to limit what components will work inside the device, not which device it will or won't connect with via a standard wireless communications format (such as Miracast).
  • Another suggestion is Mike's above, namely to allow WUDFHost.exe through the Windows Firewall. It evidently worked for him, and that is good, but I wonder why this would be necessary to get Miracast to work properly on a Surface, when it is not required on other types of laptops such as my HP Envy which, as mentioned above, connects effortlessly to the same LG OLED TV, and WUDFHost.exe is not listed on its firewall.
So many folks are suffering Miracast problems with Microsoft's Surface product line, and so many differing ideas are being tossed about, many of which are no doubt red herrings; so, why doesn't Microsoft clarify the situation as it relates to their otherwise excellent product line?

Of course, if there are any other experts out there that would care to jump in, in lieu of Microsoft's absence, it would be much appreciated.


New Member

Back again ... this time with a solution that worked for me!

As my wife's frustration and annoyance was getting to both of us, I decided to kick her off her Surface Pro 2 computer and spend the day pursuing this. Miracast now works between her SP2 computer and our TV. Here is an explanation of what I found. Note, I had already run dxdiag and it reported that the Surface was Miracast compatible.
  • Typical private/home wireless networks have a router which contains a DHCP server that assigns an IP address to all devices on the network that have not specifically been configured with a static IP address. The typical IP addresses are in the 192.168.xxx.xxx range. The bottom line is that all devices on the network must have 'compatible' IP addresses and the router effectively steers the appropriate network data between devices based on their respective IP addresses and to from the internet.
  • If understand correctly (feel free to correct me), Miracast is essentially a specific-purpose form of direct or peer-to-peer networking and does not involve the home network router.
  • For a Miracast computer to TV connection, as the router is not involved, the computer does not receive an IP address provided by the router. As a result Surface computers typically 'auto-configure' there own IP address for the direct wireless adapter, which is typically something like with a subnet mask of This not the same and not to be confused with the IP address for the home/private network used to communicate with other network devices and the internet.
  • As the TV's IP address is not typically in the 169.254.xxx.xxx range, but rather in the 192.168.xxx.xxx range, the Surface computer and TV would not connect.
Here is what I changed to resolve the problem.
  1. First I opened Settings...Network & Internet...Network and Sharing Center...Change adapter settings.
  2. I then right-clicked on the Wi-Fi network adapter.
  3. Under the Networking tab, I scrolled down the list to find Internet Protocol Version 4 (TCP/IPv4).
  4. I right-clicked it and selected Properties and then switched to the Alternate Configuration tab.
  5. Under the Alternate Configuration tab I selected Use the following IP address instead of Obtain an IP address automatically, and I entered the following IP address and Subnet mask (selected because those values were similar to ones that occurred automatically on my HP laptop that does connect to the TV via Miracast).
  6. After making that change I rebooted my wife's SP2.
Then I tried to connect the SP2 to the TV via Miracast once again (for about the 50th time). This time it worked!

I hope this will help others who have become frustrated and angry with the difficulty in getting Surface computers to connect to their Miracast-compatible TVs.
  • Like
Reactions: CSR


New Member
we are still experiencing issues with the wireless adapter, and we are using reserved IP address when they are connected to our domain, is there anything else that can be offered to help me with this issue as it is becoming a really big problem that needs resolving. we have change the firewall to allow the WUDFHOST through, we are using SP4 with the latest creator update(Don't know the name) and Microsoft display adapters V2 with the latest firmware.

if anyone have a fix for the connection dropping out that i can apply to teachers SP4's then i would be grateful


New Member
Sdavidson, I know how truly frustrating this can be.

It took a couple of months for us to get Miracast working properly on my wife's SP2, but it is now working properly. Unfortunately, none of the suggestions found on the web in this or other discussion groups provided the solution. To reiterate:
  • the problem was NOT on the receiving end (i.e., NOT the TV or Display Adapter)
  • the problem was NOT a requirement for a WUDFHost Firewall exception (both my HP computer and my wife's SP2 are working without that exception
  • the problem was NOT a requirement to force a fixed IP address as I had erroneously believed to be the answer (I apologize for my misleading comment - it did work when I forced the IP, but it only worked once and then failed to connect thereafter, and I have friends who experienced the exact same result).
Whenever the SP2 attempted to connect to the TV, they both saw one another and attempted to connect but failed. Whenever I checked the IP address assigned to the virtual Wi-Fi adapter for the connection, it was an autoconfigured IPv4 address in the 169.254.xxx.xxx range indicating that the virtual adapter was not getting a proper IP address from the TV; so, the computer was autoconfiguring one of its own. That is why I tried to force an appropriate IP address but, as it worked only once and I could not repeat that success, I continued to spend many days trying other suggestions from Barb Bowman, a very knowledgeable and conscientious Microsoft volunteer on the Microsoft Forum. None of those worked either - until she suggested that I take my wife's Surface Pro 2 into a Microsoft Store and have a tech look at it.

Because I live a 2-hour(+) drive from the closest Microsoft Store, I set up an appointment and did just that. However, after spending 20 minutes trying things, the MS tech couldn't figure it out either. He then went out back and returned with a thumb drive, plugged it into the SP2 and ran what he called a system diagnostic/repair script. I asked but he would not tell me the name of the script and he said that it is not available for download (how annoying)!

The script took perhaps 20 minutes to run and when it finished, he told us to wait as the computer would reboot within the next 5 minutes - and it did. After the reboot completed, Miracast was working.

I asked what was found and replaced by the diagnostic tool but was told that the tool does not issue a report. So, although Miracast is now working on my wife's computer, I remain frustrated that I do not know the cause or correction of the problem. My friends with the exact same problem live about 6 hours from their closest Microsoft Store, so taking their computers in for this fix is not an option, and I have no answer to give them.

However, if you happen to live within driving distance of a Microsoft Store, perhaps it would be an option for you.

I hope you get it working.


New Member
unfortunately there is no Microsoft store around me the closest Microsoft anything is in London, I will have to keep searching for an answer


New Member
In addition to the suggestion of heading to a Microsoft Store, the main point to be considered is that you may not find a solution. Even the Microsoft tech could not find one, and I had previously been to three other 'local' tech gurus (Best Buy Geek Squad and two other computer shops) before going to Microsoft - none of which could 'find' a solution.

The problem may be some slightly corrupted Windows system file or some obscure setting that only something like that mysterious 'diagnostic/repair script' can correct. I cannot understand why Microsoft does not make this repair tool available, as it is their software that was at fault in our case and I presume many others' - but it is what it is (or, que sera, sera)!

In our case, the drivers were all up-to-date, and all diagnostics that I ran indicated full Miracast compatibility, but it would not work until that mysterious file was run to diagnose and correct any errors or problems found.

I wish you good luck. Please post back if you find a solution that can be identified to help others. Thanks.