What's new

Surface Pro 3 type cover sporadically pressing keys

Inventor22

New Member
Hi everyone,

I've been using my new SP3 (i7, 512) for a week now, and today the type cover stopped working.

The typecover will stop responding altogether (windows key, function keys, character keys) except the keyboard backlight brightness buttons. Then, sometimes it will continue to press the same character, or combination of characters. The most common key press is the 'F5' key, which defaults to the 'share' function of Win 8.1.

Oddly enough, most times these repeating character sequences will stop when I remove the typecover from the SP3. On two occasions, the char sequence would still repeat after I removed the type cover. The on screen keyboard was not shown at this time either. This suggests that the issue is (thankfully), software/firmware related, rather than hardware.

In another case, the 'ctrl' key seemed to be stuck in the 'pressed' state, and this affected the on screen keyboard as well.

If I remove the typecover and reattach it after about a minute, it will function normally for ~30 seconds, and then experience the issues mentioned above.

The issues only appear when the type cover is attached, and then sometimes go on to affect both typecover functionality and on screen keyboard functionality.

I was working in OneNote when I experienced problems one time, and the result was as follow:
Vfdbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
Zxc
wwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwwzxcw
The issue only stopped when I removed the typecover.

I've taken as many steps as I could find to try fix this problem, but to no avail:
  1. Remove, then reattach keyboard
  2. Restart PC
    1. First with keyboard attached
    2. Second with keyboard unattached
  3. http://www.microsoft.com/surface/en-us/support/hardware-and-drivers/troubleshoot-surface-keyboards
    1. Installed windows updates (including all optional ones) and restarted
    2. Verified good connection and cleaned typecover connection pins
    3. Ran the Surface Troubleshooter found in link above (can post diagnostic info if necessary)
    4. Filter Keys turned off
  4. Uninstalled type cover firmware/driver using Device Manager, restarted, let windows reinstall driver
    1. Surface Type Cover Firmware Update
    2. Surface Type Cover Filter Device
If anyone has any idea what might be going on here, or other troubleshooting steps I can take, I would really appreciate the help!

Thanks,
Inventor22
 

malberttoo

Well-Known Member
The typecover will stop responding altogether (windows key, function keys, character keys) except the keyboard backlight brightness buttons. Then, sometimes it will continue to press the same character, or combination of characters. The most common key press is the 'F5' key, which defaults to the 'share' function of Win 8.1.

Oddly enough, most times these repeating character sequences will stop when I remove the typecover from the SP3. On two occasions, the char sequence would still repeat after I removed the type cover. The on screen keyboard was not shown at this time either. This suggests that the issue is (thankfully), software/firmware related, rather than hardware.

In another case, the 'ctrl' key seemed to be stuck in the 'pressed' state, and this affected the on screen keyboard as well.

If I remove the typecover and reattach it after about a minute, it will function normally for ~30 seconds, and then experience the issues mentioned above.

The issues only appear when the type cover is attached, and then sometimes go on to affect both typecover functionality and on screen keyboard functionality.

I was working in OneNote when I experienced problems one time, and the result was as follow:

The issue only stopped when I removed the typecover.

I've taken as many steps as I could find to try fix this problem, but to no avail:
  1. Remove, then reattach keyboard
  2. Restart PC
    1. First with keyboard attached
    2. Second with keyboard unattached
  3. http://www.microsoft.com/surface/en-us/support/hardware-and-drivers/troubleshoot-surface-keyboards
    1. Installed windows updates (including all optional ones) and restarted
    2. Verified good connection and cleaned typecover connection pins
    3. Ran the Surface Troubleshooter found in link above (can post diagnostic info if necessary)
    4. Filter Keys turned off
  4. Uninstalled type cover firmware/driver using Device Manager, restarted, let windows reinstall driver
    1. Surface Type Cover Firmware Update
    2. Surface Type Cover Filter Device
If anyone has any idea what might be going on here, or other troubleshooting steps I can take, I would really appreciate the help!

Thanks,
Inventor22

Hi, welcome to the forum.

Mine very occasionally stops responding, but nothing like the trouble you're having. I wouldn't waste any more time on it, and just get it replaced.
 
OP
I

Inventor22

New Member
I bought the SP3 & keyboard in the US, but I am back in Canada now. The closest MS store is in Toronto, which is a 2hr drive away for me. Would you know what my best option is?
 

Members online

Top