What's new

Surface Type Cover not recognized, likely due to a driver issue


New Member
hi all,

i have a surface pro 3 with a type cover 4 (i got the surface pro4 type cover) running windows 10 and the type cover is no longer being recognized out of the blue.
I have tried many troubleshooting methods, but none have worked so far.

I opened device manager and i noticed the only keyboard category driver i have is the HID Keyboard. Looking in other threads on this issue, it seems i should have a driver for "Surface Type Cover Filter Device" or for "Surface Type Cover"
Does anyone know where i can find the driver for the type cover 4?

Troubleshooting steps i already initiated and none of them have worked so far:
* unclicked and reclicked the keyboard many times, while connected to the internet
* did a two button shutdown/reboot
* brought the computer up to date on windows update, did reboots, shutdowns, nothing
* reset the laptop (while maintaining all data) and then installed windows updates again + some more reboots
* installed the latest "SurfacePro3_Win10_10586_1702002_0.msi" drivers & firmware pack for surface pro3 from Download Surface Pro 3 from Official Microsoft Download Center
* *tried* to install the latest "SurfacePro4_Win10_15063_1702001_0.msi" drivers & firmware pack for surface pro4 from Download Surface Pro 4 Drivers and Firmware from Official Microsoft Download Center but it did not work since i have the surface pro 3

i cannot get the driver to show up anymore, and given that i never uninstalled or deleted it, i don't know what else i can do.
I am traveling and don't have access to a microsoft store to purchase a new keyboard so i am stuck and i would appreciate any help in further troubleshooting or locating the proper driver for the keyboard.

thanks in advance!
Mine shows a "Surface Type Cover Filter Device". But only when the cover is attached. If I detach the keyboard, that goes away.
Maybe it is hardware, so the driver isn't showing.
I have the exact same issue as michmike. This all started when I put it in sleep mode one day and it decided to update. When it came out of sleep mode it finished installing and immediate stopped working.

I even updated to the new creator version of windows. I even asked for a a friends softcover. When another softcover was installed, it faintly is backlit (unlike my original) but still has not functionality.

Could the entire mechanism that runs/reads the softcover have died? I have a friend who's wireless internet components simply stopped working and there was nothing they could do.
thank you Wayne, so that does make sense and that may be the cause why.
I have the same issue as well, and this doesn't seem to be an isolated issue with so many people experiencing the same. I'm one frustrated customer, I could get no method to make the missing 'Surface cover filter device' appear on my device manager. My surface pen doesn't work either, the eraser button works but the tip doesn't function. I've vented my anger on social media with the hashtag #SurfaceProSucks. There is no customer support from Microsoft for out-of-warranty devices. very frustrated.