What's new

Surface Pro (Win 8.1) cant find Push2Tv 3000.

z3razerviper

New Member
Hello this is my first post here and I have already searched for but found no post that has solved my problem. I did a factory reset of my SP then installed win 8.1 from the market. I then installed the updated wifi drivers and updated the firmware on my push2tv to the latest firmware which i think is 2.4.19 sorry don't have it in front of me. And when I search for the wireless display my surface cant even find the push2tv. I know its working because my nexus 7 2013 sees it just fine..What am i doing wrong? Oh yea I have tried disabling the windows firewall as well to no avail......
 

robertnd2

New Member
I am experiencing the same problem. Worked fine until I upgraded from Windows 8.1 Preview to Windows 8.1 Final on Thursday night.
Marvell driver is up to date. I guess I will try the most recent PTV3000 driver, but I am not optimistic that this will fix it. It works fine with my android device. AS you said, Windows doesn't even "see" the PTV device, which is really strange.

Please let me know if you find a fix...Thanks.
 

darth21

New Member
First post here and same problem : my surface pro 2 doesn't "see" my push2tv and so can't connect to it.
And i can't check if the drivers are up to date, the Intel site doesn't recognize the Pro2 ...

I'm stuck...
 

foujax

New Member
I just tries the workaround described in the link you posted, it worked. Thanks !
I hope the issue will be fixed soon but you made my day :)
It's great that it worked for you in some way. In fact, it seems that the workaround appeared a few minutes after my post.

Well... so my device is detected, but now the Surface asks me to push a WPS button... a button that obviously doesn't exist in my blu-ray player...

Yeah...
 

darth21

New Member
Maybe you can find it in a menu of your bd Player. The push2tv displayed it on screen when i connected to it.
 

foujax

New Member
Nope. I called Panasonic about it. Their answer : Only supported with Android.

Translation : We don't know, and we don't care.

I read somewhere else that somebody asked a similar question via email. He got a pretty generic reply. So the player is back in its box and goes straight back to the store.

I think I'll wait for a while.
 
Search tags for this page
netgear ptv 3000 surface pro v1
push2tv 3000 surface pro
push2tv surface

push2tv surface pro

push2tv surface pro 2

push2tv surface pro 3
surface pro 2 and push2tv
surface pro 2 push2tv
surface pro 3 push2tv

surface pro push2tv

Members online

Top