What's new

Surface reads SD card as "Read Only"

Danja91

New Member
I'm using a Sandisk 64 GB SD card on my surface for music and games. After finding out that libraries don't support the SD card its native state, I used the Disk Management plugin to unmap it from its drive letter and mount it in C:\SD Card. I then created a "Games" folder and started to install Oblivion into it from a ripped ISO. The installation took too long (I had to go to class) so I cancelled it. When I came back home and tried to reinstall, the problems started.

I tried to install Oblivion again and right away the installer told me it didn't have permission to write to the folder. I check the folder properties and it was indeed marked "read only". I unchecked the box, hit apply, and waited for it to process all the subfiles. I then tried to install again and got the same error. Confused, I re-checked the folder properties and it was again marked "read only".

I got around the issue by dismounting the card, creating an "Oblivion" subfolder, remounting the card, and installing to that subfolder. However, this is not an optimal solution; I'm already running into problems because I can't install the mod manager; it keeps telling me it can't obtain write permissions to the subfolder I want it to download mods to. Is there any way to force the "read only" setting to off?

On a completely unrelated note, is there any possible way to disable the calendar while using OneNote? Note taking on the Pro is spectacular and exactly what I wanted; my only problem is that I tend to rest my palm on the screen. When I write across the page, I tend to graze the time/date in the bottom right corner with the side of my hand, which brings up the calendar and requires a tap to make OneNote the active program again. This happened at least 10 times today during my two hours lecture; it's a bit annoying because if I'm looking at the lecturer while writing I don't notice it, and look down later to find my first stroke after hitting the button was missing. Is there any way to disable that behavior only while using that program?

Thanks!
 

leeshor

Well-Known Member
Welcome to the forum

On the SD card problem, have you considered reformatting the card? Cancelling the install may have corrupted the card.
 

bertopl

Active Member
I thought the folder properties checkbox only worked for the contents of the folder and not the folder itself. have you tried the attrib -r on the folder in an administrator command line?

-- berto
 
OP
D

Danja91

New Member
Thanks to both of you. I reformatted the card and, while it didn't remove the "read only" flag, I'm now able to mount it and use it like a folder without issues which is good enough for me. Thanks for your advice!
 
Search tags for this page

can you load programs in sd cardon surface rt

cant play video off my sd cardon my ms surface

microsoft surface how to read only off on onenote
microsoft surface sd card read only

sd card for surface

sd card in surface is read only

search surface pro sd card

surface currupt sd card

surface pro microsd read only

www.surfaceforums.net 3734-surface-reads-sd-card-read-only

Members online

No members online now.
Top