What's new

Surface RT wifi connection issue


New Member
I don't have a permanent connection at home and rely on my Nokia E72 (Joiku Spot Pro) and HTC One V for tethering. My Acer S3 can connect on both, but the Surface RT can only connect on the HTC. I believe the Nokia is too old to be recognized by the Surface.


Well-Known Member
I brought my Surface to work last week and upon initial wifi setup I got the 'limited' indication. I rebooted the Surface and the problem immediately went away. I've taken it back to work several times since then and never had a reoccurrence; it always auto-connects.


New Member
This morning, I experienced the "Limited" issue with WiFi. As expected, it is due to an APIPA addess assigned to the network adapter. I asked the network guy to check it, and as he was making adjustments, I saw the IP address change from a duplicate IP address, then to a .13 which is reserved to some of our servers, then finally to a valid .109 that finally gave me th connection. In this case, the issue was either the tech guy or our Cyberoam appliance.


New Member
Here is my story. The Surface did not connect at the mall on my Android as stated. Last evening I did the system refresh and reinstalled the 11 updates and the Surface connected to my Android phone via FoxFi. The device worked fine this morning on my home network and FoxFi! I just navigated to the windows update to download the updates from November 13, 2012. After this update my Surface will connect to my home router but NOT the Android phone. Bummer.

Just curious is anybody has had any luck with FoxFi and hooking up to their Surface? I don't have any issues hooking up with my home wifi, but when I tried to hook up wit FoxFi yesterday it wouldn't connect? If you haven't used Foxfi before it's a app through the Google Play store that let's you use your hotspot functionality on certain adroid phones for free without alerting your carrier. It was free up until a couple of weeks ago, and then the developers (I don't blame them at all) decided to charge for the app. I have used it for 8 solid months with connecting to my O.G. Ipad with no issues whatsoever. Anyway you have to buy a $7 key to unlock unlimited usage of the app, which was fine because for $7 I don't mind paying for something that is going to let me tether my phone to my Surface without paying the extra fees that the carriers want you to pay. I saw the comments here about FoxFi and wanted to see if anyone wanted to chime in with some experience on the matter?



New Member
Has anybody tried it since the December update? I had heard there was a Surface RT fix, but it didn't seem to fix this problem for me. Anyone else?


New Member
WiFi N doesn't work

b/g works fine. It is N that is broken. I had to downgrade my router to b/g mixed to get my Surface to connect

Neither my wife nor I have a problem with our wifi connection. For what it's worth here are our settings:

Router: Verizon FiOS MI424WR (75/35 Mbps)
Connection Type: DHCP

Wireless Status

Radio Enabled: YES
Channel: Automatic
Security Enabled: YES
WEP 802.1x: N/A
SSID Broadcast: Enabled
MAC Authentication: Disabled
Wireless Mode: Mixed accepts 802.11b and 802.11g connections
Received Packets: 197499717
Sent Packets: 321085430


New Member
Yes I am having same issues. At one location I was never able to sign on. Today at a coffee shop, it took three tries and the connection only lasted 7 minutes. Hard to watch everyone else around be enjoying wifi. I have no problems at home with connections.


New Member
I'm trying to connect my Surface to a Linksys E2500 router using Cisco's Connect application. The Surface displays a message stating it cannot run the application. Does anyone have any idea why this is so, and how I can get around this?


Staff member
The Cisco software will not work on Windows RT, Cisco needs to create an App for Windows RT and from what I'm hearing is that they don't want to abide by the programming paradigms and want access to the Windows KRNL.


You should be able to just push the WPS button on your Cisco then choose your wireless network on the Surface and it should connect. Unless of course you've disabled that on your router.