What's new

Surface RT will not go online.

rikkelise

New Member
Hi guys,

I bought my first tablet computer 3 days ago, the Surface RT. I also bought wifi network: NETGEAR N. router WNR2000v4 at the same time, so I could go online.

After I got it started it recognized the network and there was no problem. Yesterday the battery was low and I set it to recharge. After I started it up again it won't go online.

I have a laptop and it goes online fine, so router seems to be working. I also re-booted the router several times.

I tried to get the tablet to find and fix the problem. It says it cannot fix the problem, and the problem seems to be with the driver of the wifi card.

Is there anything I can do about that?
 

Omni

Active Member
Your not providing enough information. Is the RT connecting to the WiFi at all? If its not it could be disabled or just need to manually connect which my RT does make me do from time to time.
 
OP
R

rikkelise

New Member
Thanks for replying.

As far as I can tell it is not connecting to the wifi at all. It says: no network was found. And it has a red line crossed over. How do you manually connect?
 

Omni

Active Member
The red cross means the WiFi adapter is disabled. Go to device manager and enable it.
 
OP
R

rikkelise

New Member
Okay, I am danish and the tablets language is danish. I have found the device manager, but can't see any wifi adapter. I have 3 'network cards', one of which is called Marvel AVASTAR wireless-n network controller. Is that the one? There are also 2 bluetooth cards. They all seem to be enabled or active.

I have also found out how to manual connect, when I try it says: error occurred.

Btw I have found a post from a microsoft page where a guy had the same problem after sleep mode and he uninstalled the network adapter, rebooted the tablet and let it find and reinstall the adapter. Might be what I have to do.
 

Omni

Active Member
Try uninstalling it and then restarting. You will need to connect to your WiFi network again with the password.
 
OP
R

rikkelise

New Member
I restarted the tablet, cause the other guy in microsoft forum said that helped his problem, and that fixed the problem! I'm online :)

Thanks for trying to help Omni. Apparently some RTs have a problem after sleeping mode.

Edit: I see you posted the solution same time as I posted lol. Yes restarting did the trick.
 
Search tags for this page
marvell avastar surface rt
marvell avastar wireless n network controller problems

marvell avastar wireless-n network controller

marvell avastar wireless-n network controller surface
marvell avastar wireless-n network controller surface rt
surface rt marvell avastar not working

surface rt marvell avastar problems

surface rt marvell wont connect to wifi
surface rt n network

the marvell avastar wireless-n network controller

Members online

No members online now.
Top