What's new

Update (08/10) Killed My SP2


New Member
I was working on my SP2 this morning. When I got ready to shut the system down it gave me the option to update and shut down or update and restart. I picked the restart option and it updated and seemed to restart fine; however, I left it alone and the system went to sleep. When I tried to wake it up I got nothing. I hit the windows button a couple of times and could feel the vibration. I then tried holding down the power button to force a restart and nothing happened. Now the thing is completely dead.

It won't respond to the 20 second power button reset nor the volume up + power button UEFI boot command. It had 70%+ charge when I was using it, but just to be sure I've connected it to the charger and still nothing.

I have no idea what the update that showed up today was for. I used the SP2 for about an hour yesterday and it didn't download any updates. It just showed up today which is odd.

Any ideas? If I can't get it working today I guess I'll try a Microsoft support call in the morning.


"Completely dead" is a (huge) problem regardless of "cause". IOW the update could have been a coincidence, and not the source of the problem.

Of course, it really doesn't matter. Whatever the reason, if it's truly dead, a replacement is necessary. If tech support can't help you revive it, I'd bet they'll offer to have you send it in (or bring it back if you bought it locally).


New Member
Turns out it's not completely dead. I noticed sometimes I could feel the vibration when hitting the windows button so I decided to hook it up to an external monitor using a mini displayport-VGA adapter. It worked, but the screen on the SP2 won't work at all. There isn't even a flicker of the backlight trying to come on. It sounds like the issue in this previous thread.


I looked at the update history and the 7/8/14 system update was reapplied yesterday. It was originally installed on 7/12 so something out of the ordinary must have triggered the second installation. I'm also getting the error where I'm being asked to reenter my most recent Microsoft password and a system file check shows unrecoverable errors.

I'm going to try a full system restore tonight and see if that will fix it. If not I guess it will be off to Microsoft for a replacement.

edit 8/12/14

Did a full restore with no luck. I can actually see the display working if I shine a flashlight on it but the screen backlight won't come on at all. It otherwise is working perfectly. I'm out of options at this point and Microsoft troubleshooting didn't get any further. I've got a replacement on the way. Hopefully it will last until the Broadwell SP4 comes out next year.
Last edited:


The repeating update thing has been a frequent nuisance--I've noticed its occurrence a number of times. How much it's a source of problems isn't clear at all, at least, AFAICT there's been no evidence of harm. You can "reset" the update database which is supposed to stop the repeating, though the benefit isn't permanent in my observation.

I don't think there was necessarily anything "extraordinary" that triggered the repeated update. The loss of password and file system errors might point to a disk failure. Even if the sys restore seems to work, I don't know if I'd consider the machine trustworthy--replacement is probably the better option.

Members online

No members online now.