What's new

Solved Wifi Not Working... No updates, nothing new

Zkyevolved

Active Member
Hello everyone! And good morning! I'm having a serious issue with my SP4 that I had never encountered. My SP4 won't connect to any wifi. I have 2 routers, it won't connect to either of them. I even created a hotspot on my phone just to make sure that my routers weren't the isssue, no go either.
I've:
  • Restarted the routers
  • Restart my SP4
  • Force restarted my SP4 (with power + vol button until it turned off)
  • Gave it a static IP
  • Uninstalled the driver from device manager (and restarted)
  • Disabled the adapter and reenabled it
Nothing has worked. There have been 0 changes in my PC

Sometimes it connects to the router, and says "no internet, secured"

I'm actually leaving for a trip for 3 days... I was thinking about only taking my SP4 with me... I guess I can't :(... Does anyone have any ideas on how to fix this? Thanks.

UPDATE: What in the world... I turned it off, after being really stressed out, and decided to give it another try.... So 15 minutes later I turned it back on and it just worked.... BUGGY! Come on MS!
 
Last edited:

HeavyHanded

New Member
Yeah. Microsoft needs to drop Marvell (the wifi chip maker) and get someone else, anyone else. My Surface 3 has similar problems.
 
Search tags for this page

microsoft surface no internet secured

no internet secured wifi on surface pro

surface pro 3 wifi no internet secured

Members online

No members online now.
Top