What's new

Windows 10 10525 runs on Windows.old files


I found I weird behavior after I upgraded to 10525 and made a reset.
When I run the "cleanup" and remove previous versions of windows, it completes but leaves on the disk the folder "Windows.old".
No matter how many times I run the cleanup, that folder always stays.
If I try to delete it manually (after I take ownership of it) I get errors telling that files are open.

I even reset the SP3 once more but nothing has changed on this behavior.


Super Moderator
Staff member
Haha, reminds me of the time when a dev team said they patched a program but it didn't make any difference. Investigation revealed they had been running production on the test/staging system and they were skipping that and releasing from their own rogue dev system. :) oh the embarrassment and butt hurt they got for that...


I decided to wipe everything clean (partitions included) and install W10.
To my surprise, it did activate. Last time I formatted I deleted all partitions besides WinRE and system but W10 refused to activate: had to go down the way 8.1 --> 10


After wiping everything, I upgraded to 10532 and "kinda" solved the problem:
- the folder windows.old was not entirely removed.
- manually deleting fails because of "SYSTEM" ownership
- after acquiring ownership I could remove it entirely without warnings

One small note: when wiping the disk empty, the new partition layout is much cleaner:

Partition ### Type Size Offset
------------- ---------------- ------- -------
Partition 1 Recovery 450 MB 1024 KB
Partition 2 System 100 MB 451 MB
Partition 3 Reserved 16 MB 551 MB
Partition 4 Primary 237 GB 567 MB