Solved anniversary update1903 breaks typecover

Discussion in 'Microsoft Surface Help' started by Barraquillo, Jul 13, 2019.

Tags:
  1. Barraquillo

    Barraquillo New Member

    Joined:
    Jul 13, 2019
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    yes i've seen all the threads! when the 1903 update installed its self in june my type cover immediately broke. the only thing that worked was the volume control. it was recognised, it even worked in the UEFI., but when attempting to type, nothing happened or the surface would crash with bsod. unfortunately my efforts to find a fix were complicated by some drivers being updated after the windows update. i tried update/rolling back/ compatible drivers, and all the other fixes posted online,nothing fixed it. i tried the reset, nothing. i then took the surface to a store and tried a keyboard on display. which worked. although unconvinced i was forced to think my type cover was faulty and so ordered another. when it arrived to my dismay , nothing, status quo. in a final attempt before reinstalling the O/S i restored from a system image made a couple of months prior, voila, it worked. surface updates to 1903 and it breaks again!!!!!!! i CANNOT be the only person to experience this unless there is some app on my surface that is causing the problem.....but i don't think so. Any comments/help. not sure how long i can delay the 1903 update. as a side note i noticed the when installing the update it turns off system restore.

    FIXED.
    After this post and more hours of trying i found the problem.......
    The 1903 update includes a driver package. it updates a driver in the HUMAN INTERFACE DEVICES. it changes it to a WACOM driver. roll it back to the generic USB INPUT DEVICE[microsoft 2006 v 10.0.18362.175]. i believe wacom make the pen etc for the SP so why their driver doesn't work?????
     
    Last edited: Jul 14, 2019
  2. Carolv

    Carolv Member

    Joined:
    Oct 16, 2015
    Messages:
    57
    Likes Received:
    3
    Trophy Points:
    8
    My Device:
    SPro
    Which driver was it. I have multiple drivers listed
     
  3. Barraquillo

    Barraquillo New Member

    Joined:
    Jul 13, 2019
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    if you have a driver listed in HUMAN INTERFACE DEVICES simply called WACOM then roll it back as described. this solved my problem after trying all other solutions i found online
     
    sharpuser likes this.
  4. Carolv

    Carolv Member

    Joined:
    Oct 16, 2015
    Messages:
    57
    Likes Received:
    3
    Trophy Points:
    8
    My Device:
    SPro
    Thanks Barraquillo. I don’t have that driver. I ordered a Bluetooth keyboard from Amazon that is working.
     
  5. tblrsa

    tblrsa New Member

    Joined:
    Jul 18, 2014
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Thank you, from the bottom of my heart. Your solution regarding this WACOM Driver finally worked!
     
    sharpuser likes this.

Share This Page