Cannot stop keyboard from waking up SP3

Discussion in 'Microsoft Surface Help' started by Eos Pengwern, Feb 7, 2016.

  1. Eos Pengwern

    Eos Pengwern New Member

    Joined:
    Sep 21, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ever since I've owned my Surface Pro 3 it's had the common problem that if I put it in sleep mode and pop it into my briefcase, then when I open it up a few hours later it's red hot and the battery's flat. Normally I work around this by making sure that it's fully turned off rather than just sleeping, but I'd still really like to fix the problem.

    So far, I've done all the obvious things: I've gone through all my devices listed in Device Manager and ensured that any device which has the option "Allow this device to wake the computer" has that option unticked. I've opened up a cmd window as an administrator, typed "powercfg -devicequery wake_armed" and verified that the response is "NONE". I've typed "powercfg -waketimers" and been reassured "There are no active wake timers in the system." I've verified that my Windows 10 installation and firmware are fully up-to-date.

    Nevertheless, if I put it into in sleep mode and I press a key on the type cover's keyboard, or even give the type cover a tight squeeze while it is closed, the computer wakes straight from sleep immediately. If I then open my cmd window as an administrator and type "powercfg -lastwake" it tells me "Wake History Count - 0".

    Clearly, the keyboard type cover is guilty of waking the computer up, even though it's configured not to do so and even though the computer denies that this is happening.

    Is there any way of fixing this that I haven't already tried?
     
  2. Garyjk

    Garyjk Member

    Joined:
    Feb 24, 2013
    Messages:
    120
    Likes Received:
    16
    Trophy Points:
    18
    you can give this a try just to see if it acts any differently. open control panel, click on power options. click on require a password on wakeup. in shutdown settings at the bottom, uncheck turn on fast startup. if it's grayed out, click the option to allow you to change settings that aren't available.
    also try unchecking hibernate and then disabling hibernate altogether, by going to an elevated command prompt and typing:
    powercfg -h off

    see if any of these help.
     
  3. Eos Pengwern

    Eos Pengwern New Member

    Joined:
    Sep 21, 2014
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for the suggestion, but I'm afraid it made no difference to the behaviour.
     

Share This Page