Can't find sleep mode option?

Discussion in 'Microsoft Surface Pro 3' started by ZachBui, Jun 22, 2014.

  1. ZachBui

    ZachBui Member

    Joined:
    Dec 2, 2012
    Messages:
    234
    Likes Received:
    18
    Trophy Points:
    18
    Do you guys see any option for sleep mode. I checked everywhere in power options but couldn't find it

    Thanks!
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Power Management or from the Power Button? Sleep is an option from the Power Button, Power Management has no options because it is a Connected Standby enabled machine, without hacks you won't have legacy power management options....
     
  3. ZachBui

    ZachBui Member

    Joined:
    Dec 2, 2012
    Messages:
    234
    Likes Received:
    18
    Trophy Points:
    18
    mmm for the power button. I just have shut down, hibernate, and do nothing
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Have you enabled the Hyper-V role or loaded Visual Studio? If yes, to either (VS adds the Hyper-V role by default) then Connected Standby is disabled as well as Sleep, your only choice is Hibernate or remove the Hyper-V role.

    Personally I'm going to use my Azure MSDN benefit and build my VMs there...
     
    1 person likes this.
  5. dleuen

    dleuen Active Member

    Joined:
    Feb 15, 2013
    Messages:
    163
    Likes Received:
    27
    Trophy Points:
    28
    Location:
    Littleton Colorado, USA
    My Device:
    SPro3
    I just learned that visual studio enables hyper v the hard way and uninstalling vs does not disable hyper v. Sometimes you have to wonder what MS is thinking. At least a little warning would have been nice before installing an IDE significantly reconfigures my system.
     
  6. Arnieaz

    Arnieaz New Member

    Joined:
    Oct 27, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Tucson, AZ
    My Device:
    Other
    Jeff, do all VS's enable Hyper-vs or just 13? It causes my wifi to fail on restarts! I have to turn wifi off and back on each time!
    If that's the case, i'll probably return my pro 3!
     
  7. ZachBui

    ZachBui Member

    Joined:
    Dec 2, 2012
    Messages:
    234
    Likes Received:
    18
    Trophy Points:
    18
    thank you, I didn't know that about hyperV =)
     
  8. dleuen

    dleuen Active Member

    Joined:
    Feb 15, 2013
    Messages:
    163
    Likes Received:
    27
    Trophy Points:
    28
    Location:
    Littleton Colorado, USA
    My Device:
    SPro3
    Good question. Along with disabling sleep mode, VS and Hyper-V also broke my WiFi as you mentioned. Bottom line, don't install VS on a Surface.
     
  9. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I believe VS 2012 and later enables Hyper-V....
     
  10. Brian Blaylock

    Brian Blaylock New Member

    Joined:
    Aug 7, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I've had the same problem...no sleep option on my Surface. After hours of research I learned that installing Visual Studio caused the problem. Simply uninstalling it didn't fix it. The best way to fix it is to reset the surface to facotry settings and DONT install Visual Studio.
     
  11. diddy_p

    diddy_p New Member

    Joined:
    Sep 30, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys, just picked up on this thread and thought i'd post this solution.

    basically disabling hyper-v or uninstalling visual studio for some reason doesn't actually set the feature switches in Windows correctly, leaving sleep and hibernate disabled.

    however you can force the change using PowerShell as an Admin user and running the following command and restart when prompted...:
    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

    Good luck!
     
  12. Ryan Whipple

    Ryan Whipple New Member

    Joined:
    Nov 16, 2014
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    What functionality does disabling Hyper-V remove from Visual Studio?
     

Share This Page

Search tags for this page
cant find sleep mode surface pro
,
find sleep mode
,
sleep mode in surface with hyper
,
sleep mode missing surface pro 3
,

sleep option missing from surface pro 3

,
surface 3 power button sleep mode option missing
,

surface pro 3 no sleep option

,

surface pro 3 sleep missing

,

surface pro 3 sleep option missing

,
surface pro 4 and no sleep option