Can't seem to charge my surface pro

Discussion in 'Microsoft Surface Pro' started by infernistic, Dec 4, 2017.

  1. infernistic

    infernistic New Member

    Joined:
    Dec 4, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    Hello, I was wondering if anyone else had this problem or has a fix for this.
    Two days ago, after my Surface Pro 1 shut down from running out of battery, it has unable to charge since.
    What happened - or what happens when I try to charge it, is that the charging indicator will light up for a few seconds (around 6 ~ 10) and then the light will disappear.
    What is more weird, is that when I try turning my spro on, the charging indicator WILL light up (and thus turning it on) however like above, the indicator light will disappear and thus my spro will shut off by itself (while it is starting up) (since no battery power)
    I'm sorry if this sounds like a mess, but I am extremely worried. Is there any way to fix this? I am most likely unable to purchase a new charger since it's terribly expensive, and as a student my family and I am not that well off, plus I have precious data in there.
    Thank you.
     
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,355
    Likes Received:
    1,103
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Hello, @infernistic,

    You are not the first person to encounter this. Let's try to get you up and running again.
    The charging circuit is getting a little trickle each time you connect the charger, but the battery does not have enough to sustain continuing.

    Try this:

    - With the charger disconnected, hold Power button for 30 seconds. Then release. Then press and release Power. The SP1 may start up. If it does, connect the charger.

    Let us know.
     
  3. infernistic

    infernistic New Member

    Joined:
    Dec 4, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    I have done so, and it does not start up, sadly. Why is it only receiving a 'little trickle' instead of being continuous?
     
  4. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,355
    Likes Received:
    1,103
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Next thing to try is this:

    - Leave the charger connected to the Surface, but unplug it from the mains power (the wall outlet). Now try to start it up, using first method (30 second press of Power, etc.).
     
  5. infernistic

    infernistic New Member

    Joined:
    Dec 4, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    It still does not start up
     
  6. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,355
    Likes Received:
    1,103
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Okay, now try this:

    - Connect charger to mains power (wall outlet). Connect the cable to the Surface 1 reversed from how you normally connect it. See if it starts charging, and booting becomes possible.
     
  7. infernistic

    infernistic New Member

    Joined:
    Dec 4, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro
    I have already tried that out - in fact several times over.
    It does charge (in that sense), and yes it does boot up per se, but the indicator will stop lighting up after a few seconds, and since its battery is at 0% and it will turn off while still booting
    Edit: Currently, it does not even boot up at all. However, it does seem to be 'turning on' as I have connected a usb hub which lights up when it turns on.
    The light on the usb hub shines for a mere second and goes off.
    Edit 2: holy moly! i repeated what i did again, reversing the magnet thing and spamming the power button for the Nth time. This time, the indicator did not seem to go out by itself. I waited cautiously for 10s, and decided to try my luck and turn the spro on.
    I have successfully booted it, and the indicator light did not go off. It seems to be working fine - as of now. Thank you for helping me out!
     
    Last edited: Dec 6, 2017
  8. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,355
    Likes Received:
    1,103
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book

Share This Page

Search tags for this page

best cameras