CPU stepping?

Discussion in 'Microsoft Surface Pro 2' started by SteveBorough, Jun 17, 2014.

  1. SteveBorough

    SteveBorough Member

    Joined:
    Dec 27, 2013
    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    18
    I've noticed that my SP2 4200U device reports in Task Manager a constant speed of 2.3 GHz. In any default power mode, plugged in or on battery it always reports the same speed (circled in the attached image) Is this right? I thought it was supposed to step down and/or burst depending on demand. To test the upper end of this, I've opened every program I have and pegged the CPU at 100%, still no movement past 2.3Ghz.
    Capture.JPG
     
  2. xramz

    xramz New Member

    Joined:
    Mar 12, 2014
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    0
    Have you had a look at the advanced power settings?
    You can have a look at min CPU.
    My SP2 does stepping, goes down to around .8ghz and up to 2.3 on balanced.
     
  3. SteveBorough

    SteveBorough Member

    Joined:
    Dec 27, 2013
    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    18
    There are no such options on my device:
    Capture.JPG
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    The lowest I've seen is .76 and the highest was 2.35 GHz.....do you have all of the Firmware Updates? Or is your system managed by a Domain? You missing 2 additional settings.
     
    Last edited: Jun 17, 2014
  5. SteveBorough

    SteveBorough Member

    Joined:
    Dec 27, 2013
    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    18
    I have every firmware update and its not on a Domain
     
  6. grumpy

    grumpy Active Member

    Joined:
    Dec 12, 2013
    Messages:
    252
    Likes Received:
    45
    Trophy Points:
    28
    The "High performance" plan will keep the speed at 2.3GHz. Try the "balanced" plan.

    EDIT: I just noticed that the problem occurs in all of the default power plans
     
    Last edited: Jun 17, 2014
  7. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,097
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Are you running the Hyper-V Role on your Surface? If so that would explain it, if not set it back to default and reboot and see if the other options come back.
     
  8. SteveBorough

    SteveBorough Member

    Joined:
    Dec 27, 2013
    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    18
    Yes, I'm running the Hyper V role. Does this disable stepping or just the reporting of the correct CPU speed?

    EDIT:After some research I've read that its just the reporting of the actual CPU speed when Hyper-V is installed. Stepping still occurs as normal but not visible in Task Manager
     
    Last edited: Jun 17, 2014
  9. Kalimero

    Kalimero New Member

    Joined:
    Sep 14, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem atm but i haven't installed hyper-V ( checked the windows installation). what can cause this problem?
     
  10. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    If you use a software like AIDA64 (free version is all you need), you can see the CPU clock fluctuate. It's a bug in the Task Manager. Just ignore it.
    Now does it consumer more power when you have Hyper-V turned on or off, that I don't know. I never checked, but the same software above can give you how much the system is consumer power, once you go on battery. It's under one of the many sections it has.
     
  11. Kalimero

    Kalimero New Member

    Joined:
    Sep 14, 2014
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I downloaded AIDA64 as you suggested but I dont know where to find the option to see the actual CPU clockrate. Additionally i used my surface for 3 hours for normal office work today and it used up 87% of the battery (energy save mode) so i doubt its working like it did before the taskmanager bug showd up.
     
  12. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    In Aida64, on the left column, go under Computer > Overclcok. You see "CPU Clock" listed, and the current speed of the CPU in MHz, which should fluctuate every second or so.

    And under, Computer > Power Management, you should see "Discharge rate", a value in mW, which shows how much the system is consuming power on battery.

    By increasing or decreasing the screen brightness, you should shortly see that number changing, confirming that it works. You can try to compare the power consumption with the system with and without Hyper-V. I recommend to close all programs before looking at the power consumption. Some software like Google Chrome web browser prevents the CPU from going to sleep, even if you have it minimized to get that edge of performance faster over Firefox. Network activity and playing music will also consume more power. So, when you compare, you want to have the same environment, screen brightness the same, and so on. Keyboard back lit also consumes power, so for comparison purposes you want to set it to minimum (off).
     

Share This Page

Search tags for this page

advance cpu stepping

,

cpu stepping for surface pro2