Mail App Issues

Discussion in 'Microsoft Surface Apps' started by TeknoBlast, Apr 18, 2013.

  1. TeknoBlast

    TeknoBlast Active Member

    Joined:
    Oct 16, 2012
    Messages:
    763
    Likes Received:
    134
    Trophy Points:
    43
    Location:
    Irving, TX
    Anyone else using the Windows Mail app having issues. Whenever I click on the app, It kicks me back to the Start screen. This has been going on with all three of my Windows 8 devices.

    Hope I'm not the only one and that's there's a fix soon.
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,099
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I've been using all day without issue....Server side mail problems...maybe?
     
  3. tonyz3

    tonyz3 New Member

    Joined:
    Jan 28, 2013
    Messages:
    729
    Likes Received:
    118
    Trophy Points:
    0
    This probably doesn't apply because you said Multiple devices. But do you have any Stardock programs on them. I had this issue and it turned out to go away after uninstalling modern mix. But it seemed to effect all Metro apps
     
  4. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    Not on my two devices.
     
  5. bosamar

    bosamar Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    1,453
    Likes Received:
    78
    Trophy Points:
    48
    My Device:
    RT
    My RT and Lumia 820 are both fine.
     
  6. kristalsoldier

    kristalsoldier Well-Known Member

    Joined:
    Feb 24, 2013
    Messages:
    2,314
    Likes Received:
    358
    Trophy Points:
    83
    My Device:
    SPro4
    Not on my two devices as of now.
     
  7. repinca

    repinca New Member

    Joined:
    Jan 29, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    0
    I have this problem not infrequently, but not consistently (which it sounds like is your problem), but I've had a lot of problems with it lately. The other day it took a full 60 seconds to load and then continued to crawl along for the next 60. A lot of people said after the last update things felt faster, but I've seemed to have the opposite experience.
     
  8. TeknoBlast

    TeknoBlast Active Member

    Joined:
    Oct 16, 2012
    Messages:
    763
    Likes Received:
    134
    Trophy Points:
    43
    Location:
    Irving, TX
    Yeah, sometimes it won't back out to the Start screen and there it times it does constantly. It's at random, but it does get annoying. I don't have any Stardock or any like apps installed. Like I mentioned, this happens to my Surface RT, my W8 Pro desktop, and my W8 laptop.
     
  9. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    Make sure the Mail app is selected as your Default mail app. Modern UI apps act strangely when they aren't the default, IE case in point.

    My mail app is working flawlessly and I'm running all of the latest updates with the exception of KB 2822241 and the Bing Desktops. Those have been known to cause some issues. Try uninstalling them then hiding them. Also set you updates to run manually.

    As jnj said, could be server side problem since it's happening on all your devices. Delete email accounts then re add them one by one and see if you can track down the culprit.
     
    Last edited: Apr 22, 2013
  10. pandmholt

    pandmholt New Member

    Joined:
    Jan 13, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Yes, I've just started to have this issue with my Surface. I go into my mail and am reading it and woosh I'm back on the start menu. Ive tried shutting down and restarting and it still does the same thing. Any thoughts. Thanks
     
  11. machistmo

    machistmo Active Member

    Joined:
    Nov 17, 2012
    Messages:
    790
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    Raleigh NC
    My Device:
    Other
    Can you access the account with a non-windows 8 device? Your phone for example? Maybe via the web? System File check perhaps, the old sfc /scannow?. I mean I am spi-tballing here. I had been using 2010 Pro Plus and then 2013 but I have not relied on the Mail client for some time now. In my experience it was too generic and had real performance issues. I watched it make some progress before I gave it up entirely. Before I reset my surface for the 5th time I had all apps doing the same thing and nothing resolved this for me. All Metro apps were acting the same way, except for the desktop. launch and die or launch and produce white screens that said " The page Failed to load" or that said nothing. All my other Metro Apps were behaving exactly as you describe.

    It should be noted that I tried all this on my pro and nothing worked. I was forced to completely reset the device. The Metro Apps now work, but the Firmware issue that actually drove me to FULLY RESET the device remains.

    Some or all of my Metro style apps fail to run. - Microsoft Community Try these and don't overlook this part : Check if UAC (User Account Control) is enabled. UAC must be enabled for Metro apps to work. To check, simply type UAC from the home screen and it will appear on the Settings search result. I thought that was going to be the magic fix for me, but it wasn't. Kind of annoying that UAC has to be enabled for Metro Apps to work.

    [Solved] Fix Windows 8 Metro Apps Fail To Run, Hang or Sudden Quit Anyway hope some of this works for you, it did not work for me.

    Time to walk the dog before work. 4:33am YAY!
     
    Last edited: May 20, 2013

Share This Page

Search tags for this page
mail wont open on surface pro 2
,
mail wont open on windows surface
,
mailapp not working surface pro
,

surface mail app not working

,

surface mail app white screen

,
surface mail issue
,

surface pro mail app not working

,

surface rt mail app not working

,
surface rt yahoo mail app not working
,
windows 8.1 pro preview e-mail app issues