Missing drivers and Firmware issue?

Discussion in 'Microsoft Surface Pro 3' started by DaSchnee, Aug 31, 2014.

  1. DaSchnee

    DaSchnee New Member

    Joined:
    Aug 31, 2014
    Messages:
    11
    Likes Received:
    2
    Trophy Points:
    3
    Hi everbody,
    I have my SP3 for 3 days now and I'm really enjoying it, but today I tried to mount a micro sd card. I put the card in the slot but nothing happend. After I tried a couple of other things I opend the device-manager to check if it's a driver related issue and I was greeted by this:
    Screenshot (2).png
    It seems like I'm missing a couple of drivers including "USB3.0 Card Reader" which is probably causing the SD card issues I'm having. On closer inspection and a bit of research on the internet I realised, I'm also missing "Surface Pro Touch Controller firmware" and there seems to be some kind of issue with the firmware in general because of those yellow exclamation marks on the icons.

    I have installed all updates via Windows update

    Does anybody have an idead how I could get this sorted? Many thanks in advance!

    PS My device manager is in german, I hope that's not an issue :/
     

Share This Page

Search tags for this page
missing surface pro touch controller firmware
,
surface 3 missing x64 drivers
,
surface book touch controller firmware
,
surface pro 3 drivers missing
,
surface pro 3 missing drivers
,
surface pro 3 touch controller firmware device manager
,

surface pro touch controller firmware

,

surface pro touch controller firmware missing

,
surface pro touch controller firmware yellow
,
surface touch controller firmware