Solved Screen blinks momentarily plugging in power supply

Discussion in 'Microsoft Surface Pro 3' started by tarrant64, Jan 31, 2015.

  1. tarrant64

    tarrant64 Member

    Joined:
    Mar 19, 2013
    Messages:
    135
    Likes Received:
    13
    Trophy Points:
    18
    Whenever I plug in or unplug my power supply for my SP3 the screen goes black momentarily and comes back. I would imagine it's changing some kind of screen setting - but my SP2 did not do this and it's slightly annoying.

    Can someone tell me if this is normal or there's a power setting I can change to adjust this?

    Thanks
     
  2. vxm

    vxm Active Member

    Joined:
    Jan 31, 2015
    Messages:
    136
    Likes Received:
    63
    Trophy Points:
    28
    Location:
    Warsaw, PL
    My Device:
    SPro3
    hey!

    I can't answer your question, but I noticed same thing with my SP3- I'd appreciate if someone could shed some light on that matter :)
     
    tarrant64 likes this.
  3. Gavin Lewarne

    Gavin Lewarne Member

    Joined:
    Jan 23, 2015
    Messages:
    66
    Likes Received:
    41
    Trophy Points:
    18
    Its part of the default Microsoft tuned Intel display drivers (which you can disable if you install them manually)
    basically on battery power it switches to a 48hz refresh rate and on power it switches to 59
     
    GreyFox7 and vxm like this.
  4. vxm

    vxm Active Member

    Joined:
    Jan 31, 2015
    Messages:
    136
    Likes Received:
    63
    Trophy Points:
    28
    Location:
    Warsaw, PL
    My Device:
    SPro3
    Ha, quite a surprise. Indeed I had different frequencies set depending on whether AC was connected or not. In my case, however, display driver is unofficial, i.e. not obtained through windows update. I went for new drivers from Intel and I've installed them manually- probably it's Intel's idea to change refresh rates then. Thank you GAvin!
     
  5. Gavin Lewarne

    Gavin Lewarne Member

    Joined:
    Jan 23, 2015
    Messages:
    66
    Likes Received:
    41
    Trophy Points:
    18
    No problem . and ya, I wish I could fix my stoopid doofus user name fubar
     
  6. ptrkhh

    ptrkhh Active Member

    Joined:
    Nov 15, 2014
    Messages:
    394
    Likes Received:
    77
    Trophy Points:
    28
    Right click on the desktop, click "Graphics Properties", then click "Power", click on the upper text that says "Power", and select "On Battery". Now disable the refresh rate switching
     
    vxm and tarrant64 like this.

Share This Page