Sleep Battery Woes

Discussion in 'Surface 3 (Atom)' started by gundam212, Aug 5, 2015.

  1. gundam212

    gundam212 New Member

    Joined:
    Aug 5, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I'm really loving my surface 3 but I'm running into issues with it draining unreasonable amounts of battery life when it should be sleeping and also feeling like I'm getting less than the average battery life of other users.

    Last night I charged the surface 3 completely and removed the charger before going to bed to see how much the battery would drain overnight. After approximately 12 hours I was able to check and see that the battery had drained nearly 19%.

    Now looking online I found the sleepstudy tool and it looks like the wifi device and hard drive are spending a great deal of time running but I can't figure out why.

    I've added links to my sleep study report and battery report:

    https://www.dropbox.com/s/v4gw06llhdrphdq/battery-report.html?dl=0 <-- Battery

    https://www.dropbox.com/s/n9se1zpedf218s9/sleepstudy-report.html?dl=0 <-- Sleep Study
     
  2. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    I came here looking for info on the same thing. Last night I went to bed with 71% and when I woke up I only had 49%, so mine lost 32% over night. (less the 8 hours) I had Skype, Edge and the settings apps open, that's it. The only thing running in my tray is a gesture engine I installed called TouchMe and the little cloud for OneDrive. The surface is only a few days old so I haven't installed much on it yet.

    Edit: looked at the sleep study on mine and it seems to be the wifi controller. It accounted for 87% of the activity
     
    Last edited: Aug 28, 2015
  3. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    Tried putting my Surface 3 in Airplane Mode last night but I still lost 19% overnight. According to sleep study it was still the Marvell AVASTAR driver causing the drain. So even in airplane mode it's still doing something. Tonight I'm gonna try disabling the network adapter and see if that helps.
     
  4. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    I disabled the network adapter right after posting the last message. It has been almost 5 hours and it's only dropped 2%, so it seems like that is the cause. However I'm not sure how to fix it. Is there somewhere to manually download a new driver for it?
     
  5. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    For the last few days I've been disabling the network adapter whenever I'm not using it and it helps the battery a lot. I still tend to lose about 8-9% over night, but it's better then 20-30% like before.

    Is there some way to report the issue to Microsoft?
     
  6. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    Not sure if anyone is reading these, or if I'm just talking to myself, but I'll continue to post my findings just for posterity....

    Last night I turned on battery saver mode, airplane mode and manually disabled the network adapter. I only lost 1% in 8 hours. :)

    Tonight I'll try again with just battery saver and the network adapter left on, just to see if that has any effect. Although I'm not really hopeful as most of my experiments with the network adapter on prove that it is the biggest culprit
     
    Fabian and VickiFL like this.
  7. patafoin

    patafoin New Member

    Joined:
    Sep 2, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Hey,

    You're not alone... This darned Marvell Avastar driver drains the battery too quickly compared to Win 8.1. I'm really sad to see my SP3 showing me the low battery icon when I try to use it after some hours off...
    I hope Microsoft will work on this problem. I can't believe they will let that problem like that.
    When I switch off my surface with the power button (sleep mode), I want it to sleep, not trying to make anything with the Wifi... (I unchecked the use of wifi when sleeping) so what's the point ? Mr Microsoft, help us ! your Tablet is now a desktop (always connected to charge it...)
     
  8. patafoin

    patafoin New Member

    Joined:
    Sep 2, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Dan, have you compared your new sleepstudy files to the first one you shared on your first topic ? Just to see if you have less red or orange lines in the list of "top offenders" ?
    I have only two offenders in my list : AVASTAR and another wifi related one.
     
  9. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    The first post is not mine. In my sleep study reports if I leave the wifi enabled I get red on the Marvell adapter. If I disable the adapter I get all green.

    For overnight the best way to save thebattery is to go into the network adapters section and disable the wifi adapter (Settings->Network->VPN->Change adapter options) then click the battery icon and turn on Battery Saver. With those two things set I only lose a few % overnight. But it's too much work to do every time I put it to sleep.
     
  10. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    I realize I never followed up in my last test. Battery saver did not fix the issue. The only way to cut the severe battery drain is to disable the network adapter. Battery saver does reduce the drain a bit more though, so it's worth turning on as well. But the network adapter is the main offender.
     
  11. ventmore

    ventmore New Member

    Joined:
    Oct 13, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Did you ever get this sorted. I'm having exactly the same issues. The only thing that seems to work 100% is disabling the adapter.

    I don get some connected standby sessions when the system will use very little power, but these are few and far between.

    Interestingly, I have had session where the network adapter shows over 90% use, but the overall score is still green, and the system has used next to no power at all.

    I seem to have settled the network adapter down a little by disabling the option for "wake on pattern match" in the adapter settings. I then got a result where I used a lot if power, and the HW value was 0%, but everything else was green, and there was no obvious culprit.

    I might try this out when I get a chance, and see if I can get any closer to an answer:

    Capture and view a WPA trace for connected standby diagnostics (Windows Drivers)

    Here's a couple of screenshots of my results.

    image.jpeg image.jpeg
     
  12. Dan203

    Dan203 New Member

    Joined:
    Aug 28, 2015
    Messages:
    14
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    Nope. I just disable the adapter when I'm not using the Surface to conserve power. It sucks that I have to do that, but nothing else I've tried works consistently. Even with the adapter turned off I still have times where it uses over 10% over night., but when I check the sleep study report it shows everything green.
     

Share This Page

Search tags for this page

avastar sleep study