Solved Surface Pro 2,3,4 Miracast Problem

Discussion in 'New Member Introduction & Site Assistance' started by TexanMike02, Sep 20, 2016.

  1. TexanMike02

    TexanMike02 New Member

    Sep 19, 2016
    Likes Received:
    Trophy Points:
    My Device:
    I had hell getting it working and there was almost no information. Just posting this with hopes that it will save someone some time.

    If changing your display drivers doesn't fix your miracast problem (If the miracast device and your computer both show that you're connecting but it times out) then this will probably fix your problem.

    I have no idea why the service doesn't have an exception but it doesn't. I checked on my sony laptop (fresh install of windows 10, not an update) and it is in fact in there so maybe this is just something that microsoft distributed in their surface builts?

    For some reason my SP3 does not make an exception for C:\Windows\System32\WUDFHost.exe which is the service miracast connects through. Its odd because I have a Sony Vaio Flip laptop that came with windows 8 as well and I have no problem connecting with it.

    So the long story short you need to go to windows firewall and make an exception for the service. I am going to recommend that you also change the type of network. I'm not aware of any exploit but you never know if one will be made available so I don't want to allow traffic through just any network. Here are the quick steps:

    To add the exception to Windows Firewall (You might have to do this with any other firewalls, though I won't know the steps. If you're here you know how to google and I'll trust you can figure out how to add an exception to your firewall).

    For Windows firewall: Open the setting menu and search allow an app through windows firewall, click on "Change Settings" then browse. Add copy and paste C:\Windows\System32\ into the folder and then scroll down to WUDFHost.exe.

    You will need to click on Details and add the network types. I strongly recommend that you limit it to private networks and then follow the second part of this which will change the network from public to private.

    Before you do this you will need to disable your firewall momentarily, just make sure that you reenable it. (Again, you're here so I trust you can disable your firewall or go here:

    swipe from the right

    Then click on network settings. Go all the way to the bottom the Network and Sharing center.

    At this point hit the windows key + P and connect to the device, make a note of the network that appears. When you've done that open a command prompt window and run secpol.msc

    If you get something about already being defined for another app in the store don't worry about it.

    Click on Network List Manager Policies

    Find the network that popped up in the network and sharing center when you connected to the device. It should be something like "DIRECT<blahblah>-YOURCOPUTERNAME". Double click on it, go to the Network Location tab and select private. I would go ahead and select user cannot change... (out of an abundance of safety) close that, close everything else and reenable your firewall.

    Rock on with your bad self with your 65 inch display...

    Hope it helps.

    nnthemperor likes this.

Share This Page

Search tags for this page

miracast surface to sony


surface miracast to sony