System Devices Not Starting

Discussion in 'Microsoft Surface Pro 4' started by gtmead09, Nov 5, 2015.

  1. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    In device manager under system devices, I have one called "Surface Touch Serviving ML" which is showing that it cannot start. When I attempt to update the driver, it says it is the latest version. Am I the only one on this one? I tried multiple ways to get it going but no luck. Thanks
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Did you apply the 11/2 firmware update.
     
  3. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    Yes, still happening.
     
    Last edited: Nov 5, 2015
  4. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    If I remove the device in device mgr and rescan, it says it installs and is working properly. I reboot, it goes back to cannot start / object name not found
     
  5. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    Driver 1.0.2.0, dated 8/30/15
     
  6. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    Called MS, their suggestion was wait for upcoming update even with the newest firmware
     
  7. jrg63

    jrg63 New Member

    Joined:
    Oct 28, 2013
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    I have exactly the same issue. Deleting and reinstalling the driver doesn't fix it as the problems goes away until the next reboot. I have a SB 256/i7/dgpu. I received mine on Oct 26 so it's one of the early ones.
     
  8. gtmead09

    gtmead09 Member

    Joined:
    Oct 31, 2015
    Messages:
    50
    Likes Received:
    7
    Trophy Points:
    8
    My Device:
    SPro4
    Mine is the 256, i5, 8 GB
     

Share This Page